Jump to content

Starting Experience 0


  • Please log in to reply
7 replies to this topic

#1 Guest_Morrigan_*

Guest_Morrigan_*
  • Guests

Posted 25 October 2005 - 07:23 AM

Hello,

First, thanks for providing the multi-install tool, has made things a lot easier !

One problem I'm finding though: my PCs always start at level 0, with no experience.

A value for clone starting experience is definately entered though.

Any ideas ? Levelling characters up from 0 is fun, but . . .

I'm running on windows XP.

Thanks again,

Morrigan

#2 Orions_Stardom

Orions_Stardom
  • Retired Gibberlings
  • 206 posts
  • Gender:Male

Posted 25 October 2005 - 05:42 PM

I don't have a system I can test this on at the moment - can anyone else confirm that this is happening?

#3 Guest_Morrigan_*

Guest_Morrigan_*
  • Guests

Posted 27 October 2005 - 12:43 AM

I'm not sure what I could be doing to be causing this problem. Is there any way I can set the starting xp after the multi-install, by editing a file perhaps ?

#4 Orions_Stardom

Orions_Stardom
  • Retired Gibberlings
  • 206 posts
  • Gender:Male

Posted 27 October 2005 - 01:08 AM

I think that it's in baldur.exe somewhere (hence why there are apps around to edit it for you) - TeamBG used to have an app to change it, so you could try it if you can find it, but I seem to remember it not working well with cloned games (hence why MIT has this in the first place).

What version of the game do you have? That is, do you have TOB, and are you patched? (only the official patch should make any difference). From memory, we don't support unpatched TOB for various reasons, and this could be a side-effect of that (if you have unpatched TOB). Failing that, we can only wait for conformation so we know if this is a bug in MIT, or something strange in your setup.

#5 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 27 October 2005 - 01:40 AM

I'm running with TOB, TOB patch 26498, and the Balderdash fixpack 112.

It seems likely to be a fault with my setup somehow, maybe someone else can confirm their MIT is working fine.

#6 andrewas

andrewas
  • Modders
  • 11 posts
  • Gender:Male

Posted 28 October 2005 - 04:59 PM

Well, I'd like to say that this is a subtle bug that even the most experienced coders could have missed but, the truth is, I simply forgot to read the desired setting before patching. Cant compile a new one tonight, and I ran across another bug while looking through the source. I'll try and have a fixed version ready tomorrow.

In the meantime, if you want to fix the XP yourself, use a hex editor to edit BGmain.exe in your clone folder, change offset 6B7258 to whatever starting experience you want. The default is 89'000, so you would want to enter A8 5B 01 00 .

My preferred hex editor is XVI32, which google should be able to find easily enough.

#7 Orions_Stardom

Orions_Stardom
  • Retired Gibberlings
  • 206 posts
  • Gender:Male

Posted 30 October 2005 - 01:35 PM

MIT v4.1 is now up with this fix.

Edited by Orions_Stardom, 30 October 2005 - 04:16 PM.


#8 Guest_Morrigan_*

Guest_Morrigan_*
  • Guests

Posted 10 November 2005 - 02:15 AM

MIT v4.1 is now up with this fix.

<{POST_SNAPBACK}>


Thanks for the fix - works fine now. Sorry for the delay in replying.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users