Jump to content


Photo

Black bars/borders won't go away

fullscreen widescreen scaling 16:9

12 replies to this topic

#1 Avallach

Avallach

    Ayreonaut

  • Members
  • 15 posts
  • Gender:Male

Posted 21 April 2015 - 12:01 PM

Hello,

 

 I have recently bought a new laptop and decided to test all my older games on it. Most of them, ranging from Fallout 1,2 to Planescape Torment seem to work just fine, but not Baldur's Gate 2 - SoA/ToB.

 

The game simply refuses to scale to my monitor I have tried almost everything, including changing my native resolution, installing the Widescreen patch and tinkering with the Intel control panel, but the game still launches in my native resolution with the game itself being in a tiny "box" in the middle of the black screen (My native resolution is 1920x1080. Game resolution is 1024x768).

 

I did some googling and most people told me that I have to enable "fullscreen scaling" in my Intel control panel (because my integrated card handles apparently handles all the monitor stuff), but the only option there available is "preserve screen scalling". If I lower my resolution, the rest of the options show up, including the fullscreen one - but BG2 still refuses to acknowledge the "fullscreen scaling" option and keeps launching in 1920x1080.

 

Been looking for solutions for about 2 hours now and I am becoming a bit desperate right now.

 

Thanks in advance for any answer.

 

 

EDIT: I also found out that disabling 3D acceleration makes my game finally fullscreen, but the fog of war is so ugly and pixelated and like 50% effects seem to be missing.. is there a way to keep 3D acceleration on while retaining the correct scale? :


Edited by Avallach, 24 April 2015 - 02:55 AM.


#2 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6626 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 21 April 2015 - 12:08 PM

Yes, turn off the GPU scaling ... or turn it on or use one of those options, the NVIDIA Control Panel for example has three options in the "Adjust desktop size and position", I use the first(Aspect ration) and it works for me.

Did you find this ?

 

Since I hadn't got a respnse to my question, I thought I better go and fend for myself.

So I went on a Bing Search to find a solution to my Problem And I did....  It's real simple So i thought for those who maybe having the same problem I'd list my Solutrion that I found so here you are.

 

            Intel Full Screen Gaming Fix.

To Fix Intel Scaling Glitch.

#1. Right Click on Desktop & Choose Screen Resolution.   And Change resolution to YxZ.

#2. Goto Ctrl Panel Click on Intel Graphics & Media. Scaling Option will now be avalible, Select Stretch to Full Screen and Save.

#3. Again Right Click on Desktop. And change your Resolution back to Native Resolution, Click on Accept... Now you should be set for Full screen Graphics in Games.

Edited by Jarno Mikkola, 21 April 2015 - 12:17 PM.

Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#3 Avallach

Avallach

    Ayreonaut

  • Members
  • 15 posts
  • Gender:Male

Posted 21 April 2015 - 12:10 PM

Yes, turn off the GPU scaling ... or turn it on or use one of those options, the NVIDIA Control Panel for example has three options in the "Adjust desktop size and position", I use the first(Aspect ration) and it works for me.

 

Well, the thing is, I am on a laptop which has a main (GTX 860M) and integrated Graphics card (Intel HD 4600).

 

NVIDIA Control Panel is missing half of the options (such as adjusting the destkop size and position or scaling), and instead Intel HD control panel seems to be handling that. But like I said in my main post, changing the GPU scaling in there does absolutely nothing at all. Game is still acting as if I was launching it in my native resolution with no scaling enabled. :/


Edited by Avallach, 21 April 2015 - 12:12 PM.


#4 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6626 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 21 April 2015 - 12:22 PM

Take a picture out of the NVIDIA Control P... with the Snipping tool.


Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#5 Avallach

Avallach

    Ayreonaut

  • Members
  • 15 posts
  • Gender:Male

Posted 21 April 2015 - 12:39 PM

Yep, that is exactly what I did. I double checked twice

 

 

Did you find this ?

 

Since I hadn't got a respnse to my question, I thought I better go and fend for myself.

So I went on a Bing Search to find a solution to my Problem And I did....  It's real simple So i thought for those who maybe having the same problem I'd list my Solutrion that I found so here you are.

 

            Intel Full Screen Gaming Fix.

To Fix Intel Scaling Glitch.

#1. Right Click on Desktop & Choose Screen Resolution.   And Change resolution to YxZ.

#2. Goto Ctrl Panel Click on Intel Graphics & Media. Scaling Option will now be avalible, Select Stretch to Full Screen and Save.

#3. Again Right Click on Desktop. And change your Resolution back to Native Resolution, Click on Accept... Now you should be set for Full screen Graphics in Games.

 

 

That is exactly what I did. Lowering my resolution, then in Intel graphics & Media selecting the Stretch to Full screen and saved and then changed back to native resolution. BG2 still refuses to stretch to fullscreen and I double checked twice as well.

 

Also, here are the screenshots of my NVIDIA control panel:

 

http://i.imgur.com/ssmh4p6.jpg

http://i.imgur.com/x7PuQnc.jpg

http://i.imgur.com/Ucy1Lho.jpg


Edited by Avallach, 21 April 2015 - 12:40 PM.


#6 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6626 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 21 April 2015 - 01:10 PM

Yeah, that's an Optimus system or whatever... which means you have to use the desktop screen resolution as the controller. So don't go back to the native resolution while you play the game.


Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#7 Avallach

Avallach

    Ayreonaut

  • Members
  • 15 posts
  • Gender:Male

Posted 21 April 2015 - 01:41 PM

So, you mean like changing the desktop resolution to 1024x768 everytime I launch the game?

I just did that and there's still no change (I must sound like a broken record now, lol)

 

Unless you meant something else by that? :)


Edited by Avallach, 21 April 2015 - 01:54 PM.


#8 InKal

InKal
  • Members
  • 259 posts

Posted 21 April 2015 - 10:22 PM


 

EDIT: I also found out that disabling 3D acceleration makes my game finally fullscreen, but the fog of war is so ugly and pixelated and like 50% effects seem to be missing.. is there a way to keep 3D acceleration on while retaining the correct scale? :/

 

 

 

No. Thats the only solution for your integrated graphics. Try upgrading from potato, no offence!



#9 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6626 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 21 April 2015 - 10:48 PM

So, you mean like changing the desktop resolution to 1024x768 everytime I launch the game?

I just did that and there's still no change (I must sound like a broken record now, lol)

You did go into the game play, not just the menues ?

And don't worry about what you sound like... if the result doesn't differ, there's something else that needs to be fixed. Erhm, where did you install the game to and what version of Windows do you have ?


Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#10 Avallach

Avallach

    Ayreonaut

  • Members
  • 15 posts
  • Gender:Male

Posted 22 April 2015 - 12:45 PM

No. Thats the only solution for your integrated graphics. Try upgrading from potato, no offence!

 
No offense but where did you learn to read? The jungle? If you'd read the thread you'd know that I actually have both a main card (GTX 860M 4GB) and an integrated card in my laptop. It plays GTA V or ArmA3 on high settings and stable FPS just fine. That's definitely not a "potato".

 

Sounds more like a manufacturer problem to me now, seeing how I can't properly adjust the scaling, while it worked on my old laptop (also with a main and integrated graphics combo)
 

You did go into the game play, not just the menues ?
And don't worry about what you sound like... if the result doesn't differ, there's something else that needs to be fixed. Erhm, where did you install the game to and what version of Windows do you have ?

 
Yep, I did. The gameplay (along with the menus) is still squished into a box surrounded by darkness. :(
I have the GoG version, and installed to D:\Games

 

I actually looked around and stumbled upon this thread (in which you are featured as well Jarno. :p ), and looks like no one has found a solution till this day, apart from killing 3D acceleration. :/


Edited by Avallach, 20 September 2015 - 12:48 PM.


#11 Tash

Tash
  • Members
  • 17 posts
  • Gender:Not Telling

Posted 22 April 2015 - 12:51 PM

I don't want to get in Jarno's way again, but it might be just like I said in the other thread: there are issues with certain drivers, cards, connection types and resolutions. If your native is 1080, try 1280x720 using the widescreen mod.

 

I know many people have the same issue; with hardware acceleration on, any resolution other than HD standards (1080p and 720p) results in a centered image with black borders, even with proper driver configuration.


Edited by Tash, 22 April 2015 - 12:52 PM.


#12 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6626 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 22 April 2015 - 01:53 PM

(in which you are featured as well Jarno. :p )

Yes, I kinda am a permanent feature of the Widescreen mods forum.

I don't want to get in Jarno's way again...

This is a free range and you can take your best shot any time you wish... it's actually appreciated. I don't want to do all the thinking. Or none thinking. :devlook:
Yes your point about the HD could even be a feature related to the cards internal structure.
Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#13 Avallach

Avallach

    Ayreonaut

  • Members
  • 15 posts
  • Gender:Male

Posted 23 April 2015 - 05:07 PM

I don't want to get in Jarno's way again, but it might be just like I said in the other thread: there are issues with certain drivers, cards, connection types and resolutions. If your native is 1080, try 1280x720 using the widescreen mod.

 

I know many people have the same issue; with hardware acceleration on, any resolution other than HD standards (1080p and 720p) results in a centered image with black borders, even with proper driver configuration.

 

You mean like setting the 1280x720 with widescreen or also using the option in the BGConfig?


Edited by Avallach, 17 January 2016 - 12:18 PM.




Reply to this topic



  



Also tagged with one or more of these keywords: fullscreen, widescreen, scaling, 16:9

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users