Jump to content


Photo

Black borders / small screen / scaling problem with 3D Acceleration with Baldur's Gate 2 - a solution

Black borders 3D Acceleration problem scaling problem

No replies to this topic

#1 James M

James M
  • Members
  • 1 posts

Posted 10 November 2016 - 08:22 PM

I have found a black border solution for Baldur's Gate 2 (original, patched to 26498), at least for my laptop (Windows 8.1). The Win 8.1 laptop has: integrated Intel HD 4600; and NVIDIA GeForce GTX 850M; 1920x1080 built-in display; connected to a glorious Ultrasharp 2560x1440 monitor.

Briefly: select the resolution options "Multiple displays" and "Duplicate on 2 and 3" using a cable or adapter connected to a 3rd monitor or a TV (off is OK) solves the black border/scaling problem for me with 3D Acceleration enabled, running at 1280x720.

---:::---:::---

My laptops can run BG2 with no scaling issues WITHOUT 3D Acceleration; however, wouldn't it be great to finally try the 3D Acceleration setting?

Whenever I check the 3D Acceleration box on BG2 options it does not "scale full screen" and no matter what I do I can't get the huge black borders to go away. This includes running the exe's in various compatibility modes, updating drivers, switching between the Intel integrated card and NVIDIA, disabling triple buffering and changing other NVIDIA options, and trying different monitors. It simply won't scale with the 3D Acceleration box checked.

I like to run the game at 1280 x 720 (used to use 800 x 600 when I was using my old school 4:3 monitor which is 1280 x 1024, but the Ultrasharp has a significantly better picture).


1. Install Widescreen mod; set to 1280 x 720; set monitor ("Monitor 1") to 1280 x 720 to match the Widescreen mod. Monitor is connected via the Mini DisplayPort (MiniDP) but this also works when connected via HDMI.

2. NVIDIA control panel: set BG2 to use NVIDIA graphics processor (or Integrated) and make sure triple buffering is disabled.

3. Plug in a 2nd cable such as HDMI (to a TV or "Monitor 2") or HDMI-to-VGA adapter (or USB-to-DVI); in the "Multiple displays" dropdown select "Duplicate on 2 and 3". On the graphics setting (Panel Fit / Scaling; can access with a Right-click on desktop) select "Scale Full Screen" for both 2 and 3. This option is available if you are NOT using Monitor 1's max resolution.
If using only a cable, the other end must be connected to the TV (turned off OK; it is a 1080p Samsung) or 2nd external monitor (off OK).

4. Start game, skip intro videos, go to SoA main screen -> It is not scaled; the game is very small with a huge black border.

5. Reconnect or remove/reconnect  HDMI cable (or adapter) to laptop -> Monitor 1 reverts to 1280 x 720 and has scaled to full screen! Note: the TV is off but HDMI cable must be plugged into it; at this step if using an adapter, it does not need to actually be connected the 2nd monitor.

If needed: make sure the desktop settings are still "Duplicate on 2 and 3" both 2 and 3 are set to 1280 x 720.

If ALT-tab to desktop while running the game then unplug/re-plug the HDMI cable (or the adapter) and it reverts back to scaling to full screen at 1280 x 720! Desktop must be set to 1280x720 or the Widescreen mod will fail.

---:::---:::---

Re-start the laptop so the system remembers what to do when the cable/adapter is plugged in, just to be sure.

The 3D Acceleration setting does improve the graphics by reducing the pixelation, among other things I presume, and also allows you to install the 1pp (One Pixel Productions) option called "Softer spell effects" (to do so after 1pp is installed already: select "Re-install" for components already installed). 1pp version 4.1.0 from shsforums.net does indeed work even though it says "file is corrupt".  

Note: if I had a monitor that had a full screen mode "max'ed out" to my desired resolution, I assume there would be no scaling problem.





Reply to this topic



  



Also tagged with one or more of these keywords: Black borders, 3D Acceleration problem, scaling problem

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users