Jump to content


Photo

Any Gibberlings want to sort out an EE version?


21 replies to this topic

#1 Grim Squeaker

Grim Squeaker

    Utter Bastard

  • Gibberling Poobah
  • 3298 posts
  • Gender:Male
  • Location:Hovering around London

Posted 20 February 2014 - 09:58 AM

I know it's been a while but thought I'd stick my nose in (with the release of EE).

I was wondering if a Gibberling fancied investigating an EE version of Tyris? I haven't even looked into how someone goes about doing that (or what makes the coding behave differently) but it's be nice to have the old girl compatible with the most widely available version of the game :)

"Leave me be, I don't want to argue.
I just get confused and I come all undone.
If I agree, well it's just to appease you,
'Cause I don't remember what we're fighting for."


#2 SharDaSlayer

SharDaSlayer
  • Members
  • 13 posts
  • Gender:Male
  • Location:Germany

Posted 07 March 2014 - 06:10 PM

Just in case, anyone here wants to make Tyris BGII:EE compatible:
I' ve tried to make this mod compatible for the EE and had only little success, but maybe someone here can use my findings to ensure that Tyris can soon be played in EE.
I can tell to 99.99% that there must be some error in the INTERJECT, I_T_C and other commands like that. This mod isn't the only one who suffers because ot that error. I tried to fix that, but my modding knowledge is kinda limited, especially in BGII:EE, but maybe there's a modder here who reads this and can fix that. It's a shame that we can't play this great mod in the Enhanced Edition. :)

#3 jastey

jastey
  • Gibberlings
  • 6893 posts
  • Gender:Female

Posted 08 March 2014 - 01:26 AM

there must be some error in the INTERJECT, I_T_C and other commands like that. This mod isn't the only one who suffers because ot that error.

Would you please specify what error(s) you are referring to? Stating yourself a limited modding expertise but at the same time stating that another mod must be bugged in several scripting commands is kind of contradicting, to say it politely.

#4 SharDaSlayer

SharDaSlayer
  • Members
  • 13 posts
  • Gender:Male
  • Location:Germany

Posted 08 March 2014 - 05:36 AM

If I knew, what's the exact problem with the commands, I'd fix it myself, jastey. I can only tell you, that everything but the interjections work as far as I can tell. Let me give you an examle. (There *might* be SPOILERS ahead, not only for Tyris but for other mods)
Tyris is beginning the 20th lovetalk. If you have Aerie in your group and are romancing her as well, the game crashes at the point where Aerie should interject. Same problem with the Viconia romance conflict. The other banters worked so far.
I have the Unfinished Business mod installed for a while and it worked with my self created parties so far. But as soon as I had Aerie in the party and began to talk with the girl from the Kalah quest, the game crashed - although it always worked perfectly before. I loaded, tried again and again and still: the game crashed. Then I killed Aerie and the banter worked. You can follow me, right?
Then the third mod, where this problem occured: Longer Road. As soon as the Gromnir interjection should start, the game crashed AGAIN. I removed the LR-companion and it worked perfectly. Every other banter did not result in a game crash.

I don't know, what you think, but for me it looks like the Enhanced Edition doesn't support some of the interject commands. But feel free to correct me if I'm wrong. ;)

Edited by SharDaSlayer, 08 March 2014 - 05:41 AM.


#5 Drizzt101

Drizzt101
  • Members
  • 3 posts

Posted 12 August 2014 - 09:57 AM

Just expressing another interested fans wish for this mod to be made EE compatible.

 

^^



#6 SharDaSlayer

SharDaSlayer
  • Members
  • 13 posts
  • Gender:Male
  • Location:Germany

Posted 28 October 2014 - 09:22 AM

Anyone working on this issue?



#7 argent77

argent77
  • Modders
  • 710 posts
  • Gender:Male

Posted 12 January 2015 - 06:24 AM

I always wanted to try out this mod, so on the spur of the moment I have added basic BG2:EE compatibility to this mod (and fixed some minor issues). I haven't thoroughly tested it yet, but it installed flawlessly, Tyris and her equipment looked fine so far and the few banters I've already seen worked perfectly. I didn't really change anything content-wise, so don't expect any romance conflicts with the new BG2EE NPCs, but I have set their respective romance variables just in case to avoid compatibility issues with the Bodhi abduction scene.

Let me know if you find more (technical) issues. I don't plan to extend the actual content though. If you can come up with good ideas how to integrate Neera or Dorn into the romance, feel free to use this version as a basis.

Download: Tyris Flare NPC (latest release)

Changelog:
- Added basic BG2:EE compatibility (no romance conflicts with Neera and Dorn yet)
- Fixed wrong description of her non-upgraded armor
- Fixed dependencies of the Alternate Portrait subcomponent
 
Edit: Updated download link.

Edited by argent77, 05 August 2015 - 06:50 AM.


#8 SharDaSlayer

SharDaSlayer
  • Members
  • 13 posts
  • Gender:Male
  • Location:Germany

Posted 17 January 2015 - 03:16 PM

Wow, that is great! Thanks for sharing, will download and test it at once. :)

 

Is there any chance you will add new stuff (like romance conflicts with the new NPCs), Grim?


Edited by SharDaSlayer, 17 January 2015 - 03:18 PM.


#9 argent77

argent77
  • Modders
  • 710 posts
  • Gender:Male

Posted 17 January 2015 - 03:47 PM

Is there any chance you will add new stuff (like romance conflicts with the new NPCs), Grim?

Very unlikely. Top priority is making the mod fully BG2:EE compatible. I've taken care of their romance variables however to make sure you can't woo more than one love interest at a time. ;)

 

If you can wait a few days, I'll release a second beta soon which fixes a couple of issues.



#10 SharDaSlayer

SharDaSlayer
  • Members
  • 13 posts
  • Gender:Male
  • Location:Germany

Posted 18 January 2015 - 04:54 AM

In that case, I'll wait. Installing the mod crashed anyway. :/



#11 argent77

argent77
  • Modders
  • 710 posts
  • Gender:Male

Posted 18 January 2015 - 06:21 AM

Can you show me the error message or tell me when/where it crashed?


Edited by argent77, 18 January 2015 - 07:52 AM.


#12 argent77

argent77
  • Modders
  • 710 posts
  • Gender:Male

Posted 20 January 2015 - 07:31 AM

New release: Tyris Flare NPC v7 beta 2a (outdated)

I've done a full playthrough and managed to find and fix a couple of minor issues. This will probably be the last beta, unless someone has serious issues with the current release.

Changelog:
  • Removed redundant OGG->WAV conversion. BG2:EE supports OGG directly.
  • Fixed Tyris' casting voice.
  • Fixed Tyris' Firkraag interjection.
  • Fixed Tyris' Demogorgon interjection.
  • Fixed several area script issues.
  • I had included a WeiDU beta by mistake in the previous version. Updated to WeiDU v237.
  • Beta 2a: Added missing DLL for included character conversion tool iconv.
Edit: Removed link to beta 2a.

Edited by argent77, 05 August 2015 - 06:53 AM.


#13 SharDaSlayer

SharDaSlayer
  • Members
  • 13 posts
  • Gender:Male
  • Location:Germany

Posted 20 January 2015 - 09:18 AM

During the installation, something about a missin .dll file, but it worked with the updated version. :)



#14 argent77

argent77
  • Modders
  • 710 posts
  • Gender:Male

Posted 20 January 2015 - 10:18 AM

Looks like I've forgotten to package a required DLL for the charset conversion tool iconv. I'll add it in the next update.

 

Edit: Updated (see my previous post).


Edited by argent77, 20 January 2015 - 11:04 AM.


#15 argent77

argent77
  • Modders
  • 710 posts
  • Gender:Male

Posted 23 February 2015 - 08:14 AM

New release: Tyris Flare NPC v7 final (outdated)

More recent versions can be found in the G3 Downloads section.

The final release of Tyris Flare NPC v7.

Changelog:

  • Added a string fixer script (select Tyris and press 'F' to trigger).
  • Using WeiDU's HANDLE_AUDIO for audio conversion instead of platform-specific batch files.
  • Fixed a couple of spelling errors.

 

Edit: Updated download link.


Edited by argent77, 05 August 2015 - 06:58 AM.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users