Jump to content


Photo

Problem with 3d-Acceleration and Widescreen Mod


12 replies to this topic

#1 Adeaphon

Adeaphon
  • Members
  • 4 posts

Posted 11 April 2014 - 10:42 AM

Hey guys,

I've encountered a strange problem and couldn't find any solution - neither here nor with googling. It is probably not really a problem with the mod itself, but since I have no clue where else to ask for help... here it is.

My installation consists of the GOG-Version of BGI and II as well as a (modified) Total Happiness BWP-install, although that shouldn't really matter.

When I use the Widescreen Mod wihtout 3d-Acceleration enabled, it works as intended - I get a stretched game when setting the resolution to something like 1280x720 on a 1920x1080 monitor. But if 3d-Acceleration is enabled, I can't get my GPU/monitor to stretch the picture.
I have tried it on both my laptop (doesn't work with the integrated graphics card and doesn't work with the nVidia 620m) and my desktop PC. Any help would be greatly appreciated.

Thanks a lot!

Edited by Adeaphon, 11 April 2014 - 10:43 AM.


#2 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6307 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 11 April 2014 - 11:43 AM

Take a picture with the Prt Scr key and go to the games folder, which then has a new folder that has the picture you just took, and then upload it to imageshack or Tiny pictures and then put the direct link to a post with this surrounding it, the "http-address":
[img]http-address[/img]

Unless: The most likely picture you get is this:
Posted Image
The case there is that you installed the GUI mod after the Widescreen mod, which is in BG2 a big NO NO ! As you need to install the GUI mod before the Widescreen mod.
In the other games you need to do that, but it's cause they are made to work with the Widescreen mod.

Or you tried and failed at a point in the installation as you should make sure that everything is working before you install mods to the game ! So you possibly need to restart the installation. In any case you loose.

Edited by Jarno Mikkola, 11 April 2014 - 11:48 AM.

Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#3 Adeaphon

Adeaphon
  • Members
  • 4 posts

Posted 12 April 2014 - 01:14 AM

Huh, I could've explained that much better than I have - sorry for that.

Screenshots are not something that would help anyone, as the actual problem is only with the stretching of the game. I'll just post to modified screenshots here to reflect what I actually see:

with 3d-acceleration on:
Posted Image

3d-acceleration off:
Posted Image

When I take screenshots, they are identical and have a size of 1280x720. As I said above, it most likely is unrelated to the widescreen mod itself and the GPU's "fault", but I can't figure out why it is treating the game differently when the setting for 3d-acceleration is changed. While I do understand that it actually uses the GPU for calculations and not only for drawing to the screen (at least I hope I got that right), I do not understand why a) no one else seems to have that problem and b) how to solve it. On my desktop PC (AMD graphics) there is an option for changing the stretching mode for content that has a smaller resolution than the native screen res, but that doesn't change anything. And I can't find that option in the nVidia control panel.

Thanks again for any help!

#4 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6307 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 12 April 2014 - 02:08 AM

Screenshots are not something that would help anyone, as the actual problem is only with the stretching of the game.

When I take screenshots, they are identical and have a size of 1280x720.

Hah, well the above pictures have resolution of 1600x900... so you might actually be wrong in many ways.
The reason why the later picture has the odd fog of war(the squares are wrongly placed on the lower half of the effect) is that it has the wrong setting in the sprite mirroring, to adjust that you need to probably open the baldur.ini file with Notepad and adjust the "Sprite Mirror=" -line.
Learn from this, without actually giving your own pictures, you won't know if they help or not !

But to fix all this, when you set up the game before any moding, make sure that you first of all won't install the game to C drives Program Files sub-folders, then start the game and make sure that you set it up correctly with the software 3d-Acceleration(and to ensure that, most if not all the todays computers can run the game with these settings today, run the BGConfig.exe and use these options: Hardware -> Enable 3D Acceleration. Display -> 32 bit. 2d & 3d options: enable 3D Animations, Use 3D Acceleration with Drivers: Default OpenGL Driver, and 32 bit textures, disable the Disable Vertex Padding option):
Posted Image
Then check that the options are correctly set up with the resolution of 1024x768 that the games own options give by running the game perhaps with imported character, and check that you have installed the possible patch(the game options will need to show that the game version is v2.5.26498, yes, it's shown only during a played game, not in the not started game).

Then you might wish to make a backup of the game folder. Then install the mods, like the Widescreen mod etc.
When you set up the game correctly you'll actually notice that the GPU has barely anything to influence the picture that comes out of the monitor ... because you are using the the software to run the screen.

Edited by Jarno Mikkola, 12 April 2014 - 02:27 AM.

Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#5 Adeaphon

Adeaphon
  • Members
  • 4 posts

Posted 12 April 2014 - 03:49 AM

Hah, well the above pictures have resolution of 1600x900... so you might actually be wrong in many ways.
The reason why the later picture has the odd fog of war(the squares are wrongly placed on the lower half of the effect) is that it has the wrong setting in the sprite mirroring, to adjust that you need to probably open the baldur.ini file with Notepad and adjust the "Sprite Mirror=" -line.
Learn from this, without actually giving your own pictures, you won't know if they help or not !


First of all: Thanks for your help!
Second: The resolution seems to have been changed by tinypic, since I actually took two screenshots, noticed that their resolution was 1280x720 (in both cases) and then upscaled one to 1920x1080 and left the other as is and added a 1920x1080 black background to show you what I'm seeing.
About the sprite mirroring: That I didn't know about, and when that is fixed I can actually play without 3d acceleration on quite comfortably. So that is a pretty good workaround, although it does not really address my actual problem.
What I meant with "screenshots won't help anyone" is the following: You couldn't see any differences if I only gave you the screens without any editing like I did above.

But to fix all this, when you set up the game before any moding, make sure that you first of all won't install the game to C drives Program Files sub-folders, then start the game and make sure that you set it up correctly with the software 3d-Acceleration(and to ensure that, most if not all the todays computers can run the game with these settings today, run the BGConfig.exe and use these options: Hardware -> Enable 3D Acceleration. Display -> 32 bit. 2d & 3d options: enable 3D Animations, Use 3D Acceleration with Drivers: Default OpenGL Driver, and 32 bit textures, disable the Disable Vertex Padding option):

Then check that the options are correctly set up with the resolution of 1024x768 that the games own options give by running the game perhaps with imported character, and check that you have installed the possible patch(the game options will need to show that the game version is v2.5.26498, yes, it's shown only during a played game, not in the not started game).

Then you might wish to make a backup of the game folder. Then install the mods, like the Widescreen mod etc.
When you set up the game correctly you'll actually notice that the GPU has barely anything to influence the picture that comes out of the monitor ... because you are using the the software to run the screen.


I do have the correct game version, since GOG delivers the game fully patched. The settings you gave as an example are exactly as I have set mine. The game is not installed anywhere on C:\.
I will follow your suggestion and install the game again and test it with 3d acceleration on before installing the widescreen mod, although I did try to turn 3d acceleration on and install the Widescreen Mod again - didn't change anything.

Edit:
So, yeah, I only restored the backup that BWS creates and tried it without Widescreen Mod or anything else. The results are basically the same - I get the desired result if 3d acceleration is disabled, but there's no stretching to fill the whole screen when it's enabled so that I see a 800x600 or 1024x768 rectangle in the middle of the screen with a black border (basically what is seen on the first screenshot above).

Now the question is whether the Widescreen Mod is supposed to do something about that or if everyone is getting the same issues and noone expected it to work as I did ;)

Edited by Adeaphon, 12 April 2014 - 04:19 AM.


#6 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6307 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 12 April 2014 - 04:52 AM

First of all: Thanks for your help!

Well, you and everyone is welcome to what info I have... and yeah, I misunderstood the picture reference... let's move onward from it...

So, yeah, I only restored the backup that BWS creates and tried it without Widescreen Mod or anything else. The results are basically the same - I get the desired result if 3d acceleration is disabled, but there's no stretching to fill the whole screen when it's enabled so that I see a 800x600 or 1024x768 rectangle in the middle of the screen with a black border (basically what is seen on the first screenshot above).

Well, it removes the top and lower portions of the black... and that's how it should seems to be. Unless your video card is forcibly altering the out come.
Something to this effect, yes bad cut from top picture of yours, so it's just to demonstrate the point.
Posted Image

Now then, if we make sure to play only on full screen mode, and then install the Widescreen mod to the BG2 game using a set default screen size, we get rid of the black borders inside the main game view, the menus have them yeah, but that's because the menu art is not big enough or extended to cover any of the black parts, but it won't bother you during gaming, as the thing you try to do with the Widescreen mod is trying to get a bigger view of the game, the play map.
You set the resolution size by using one of the same resolution setting you use in the Windows background, that you can find in the Customization/Resolution menu when you right click in your desktop.
Depending on your monitor, it can be 1920x1200, 1680x1050, 1440x900, 1280x800 or even 1024x640 with the 16x10 resolution ration. It's 1920x1080, 1600x900, 1280x720 or 1152x720, with the 16x9 resolution ration, if you monitor can display them, and you like the size.

Now if the video card is forcibly altering the outcome, that can be disabled, at least on a ATI cards ! I remember from somewhere... the imp goes to search his tail... EDIT: Hey I found my tail !!!
Here's the solution.

Edited by Jarno Mikkola, 12 April 2014 - 05:26 AM.

Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#7 Bryll

Bryll
  • Members
  • 8 posts
  • Gender:Male

Posted 13 May 2014 - 10:53 AM

Adeaphon, did you ever solve this issue? Also, is there a particular reason why you want to render at 1280x720 and scale up to 1920x1080 instead of just rendering at 1920x1080 in the first place?

The actual problem is probably related to GPU scaling - those settings you were looking for in your Nvidia control panel and couldn't find. Nvidia removed them at some point. I believe there's still a way to get at them, but I don't remember off the top of my head and don't really want to spend the time researching if your problem has been solved. EDIT: I see that ATI's scaling options did not work for you. I see that you're experiencing this problem across multiple PCs, and not just your laptop like I thought. Usually I'm the one telling people to read the damn thread, but it seems this time the problem is me.


I'll have a look at this in a bit when I have a windows machine up and running again - probably in a few hours. I'll post back with whether or not I can reproduce the problem.

Edited by Bryll, 13 May 2014 - 01:37 PM.


#8 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6307 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 13 May 2014 - 11:56 AM

Also, is there a particular reason why you want to render at 1280x720 and scale up to 1920x1080 instead of just rendering at 1920x1080 in the first place?

Well, one could wish to play in 1280x720 mode. As in, one wants to be able to see the tiny things larger. Or from 15 feet away from their TV that's smaller than say 5 feet diagonally.
Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#9 Adeaphon

Adeaphon
  • Members
  • 4 posts

Posted 25 July 2014 - 01:25 PM

Sorry for the late reply, got distracted by life... :)

 

I was pretty sure I had it solved at least for my desktop PC, but now have the exact same problem again.

I got myself a new GPU (still AMD) and reinstalled BG as well as the Widescreen Mod. In the CCC, GPU-Scaling is activated and set to "Scale to Fullscreen" (or something like that). But I just noticed something strange: If I start BG (with 3D acc on, so it doesn't scale) and then Alt+Tab to the CCC, the scaling-mode is set to centered and then jumps back to my original selection. So all in all it seems to be pretty weird...

 

And, as before, if 3D acceleration is activated (like in the imps screenshot above) it doesn't scale but if it is off it does scale exactly like I want it to.

 

@ Bryll: Yeah, the Imp is right. I want to be able to read stuff comfortably which works pretty well with upscaling. Could you reproduce my problem? And if yes, did you find a solution?



#10 Atreyu83

Atreyu83
  • Members
  • 2 posts

Posted 26 November 2014 - 04:46 AM

Hi Adeaphon,

 

I have the same problem you encountered and I'm trying to solve it getting some info from forums and googling around. I'll tell you what I got by now. First of all the specs of my laptop and the description of the problem so we know what are we talking about:

Sony Vaio Pro 13 (SVP1322C5E)

Intel HD Graphics 5000 (no additional graphic card)

Resolution 1920x1080

(others available are 1280x1024 and 1024x768)

I first encountered your problem with the fully mod "Baldur's Gate Trilogy" I got from GOG following this guide on GOG.com website. I thought it was something related to the various mods (like the widescreen mod you were talking about) so I tested if I was getting the same problem since the beginning and this is the case actually.

I did a fresh install of both "Baldur's Gate - The Original Saga" (v1.3.5521) and Baldur's Gate 2 (v2.5.26498), the last versions downloaded from GOG.com. I describe you the behavior of those two fresh install.

Baldur's Gate - The Original Saga: game works full screen, image seems a bit stretched (probably adapting the game resolution to my screen resolution), resolution is 640x480 as you can see from the image below. The game is playable, no strange behavior, no flickering of the image or of the hand cursor (I'll come to this later).
 

Baldr000.png


Baldur's Gate 2 Complete: using BGconfig.exe I set up the "Display" section and the "2D & 3D Options" section as you can see from the images below. I enable "Use 3D Acceleration". When I apply those settings I'm asked about performing the usual test where I already notice the problem: the 3 rectangles (red, green and blue) are in the middle of the screen surrounded by black bands. Those have the right dimension and I see them shrinking if I select 800x600 or 640x480 game resolution. I tried to do some snapshots of those tests, but every time I get a screenshot of my desktop area underlying the rectangles. I don't know if this can be a problem yet or if it has something to do with the OpenGL window test.

BG2_Display.png

 

BG2_2_D3_D.png

 

The game in this case is playable but just too small: I get the 1024x768 game resolution at the center of my 1920x1080 desktop resolution so without any stretching, no fullscreen. I made a snapshot of the in-game image but what I get is only the game area (the OpenGL area?) without the big black borders I usually see. The resolution of this image is 1024x768 as expected (see below).

 

Baldr000.png

 

This is with the "Use 3D Acceleration" option turned ON; if I turn it OFF I get the correct full screen behavior of the rectangles. Playing the game the game image get stretched and so deformed (I think this is my graphic card acting now and it wasn't doing anything before). The game is hardly playable because the hand cursor is flickering and sometimes pieces of my desktop appear on top of the game image. I took a snapshot but again this one looks good, 1024x768 resolution, no stretching, no artifacts. So it seems now that without 3D acceleration my graphic card is stretching the OpenGL image correctly but now producing those artifacts.

I think I should stop now with my tests, without applying any mod and try to solve this problem first. This is the fundamental issue. Hope this description will be helpful for you all to understand my (our) problem and to try to find all together a solution.

Thank you for reading, bye!



#11 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6307 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 26 November 2014 - 05:25 AM

I think I should stop now with my tests...

Try and disable the GPU scaling, when the 3d acceleration is on... how, ask the manufacturer, aka Intel. Or read the last post here.

The link was easy to find, just put "intel hd graphics 5000 scaling problem" to google without the quotes... so doing that type resource finding should result to a solution.


Edited by Jarno Mikkola, 26 November 2014 - 05:32 AM.

Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#12 Atreyu83

Atreyu83
  • Members
  • 2 posts

Posted 01 December 2014 - 01:53 PM

So, I think I finally found a solution. Well, it's more a workaround than a real solution since it works only if I deactivate the 3D Acceleration.

Just to summarize: my Intel HD Graphics 5000 doesn't allow "Scale Full Screen" on Panel Fit settings when set on native resolution (1920x1080). Even if it allows this option when set to lower resolutions and I set it the game runs always 1920x1080 with the small game image in the middle (the OpenGL window) at the resolution set by the Widescreen Mod (that I installed and set to 1280x720). Now, deactivating the "Use 3D Acceleration" option in the configuration settings (BGConfig.exe) under the section "2D & 3D Options" allows (for some reason I'm not able to understand) my graphic card to perform the stretching properly. Anyway, when I set this option I get another problem: the in game hand cursor is flickering and the screen sometimes shows parts of my desktop area. The game with those settings is really unplayable. I was finally able to solve also this other problem by installing the "Aqrit's DDrawFix for Infinity Engine games" mod and setting it to "Use WineD3D's DDraw Library".

So now I'm able to play at the resolution I want but without 3D acceleration. I'm not 100% happy, but at least now I can play the game.

Hope this will be helpful for anyone who had a similar problem.

Thank you.



#13 Torgo

Torgo
  • Members
  • 25 posts

Posted 13 November 2017 - 12:12 PM

I think I found a solution that works without disabling 3D acceleration:

1. Download DxWnd and extract the archive.
2. Run dxwnd.exe.
3. Go to Edit > Add.
4. Under the Main tab, enter the path to bgmain.exe.
5. Under the Generic section, uncheck "Run in Window." This will restore your display resolution when the game is minimized.
5. Under the Input tab, Cursor handling section, uncheck "Correct mouse position."
6. Click OK.
7. Double click the newly created icon that appears within the DxWnd program window to run the game.





Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users