Jump to content


Photo

Mod Compatibility List for EET


669 replies to this topic

#1 K4thos

K4thos
  • Modders
  • 876 posts
  • Gender:Male

Posted 07 January 2016 - 05:36 AM

MOD COMPATIBILITY LIST FOR EET
Last Updated: 06.02.2017

 

This compatibility list will be frequently updated. It is highly recommended that you follow what is said here if you are planning to make EET installation with mods.

 

EET project aims to be a mod friendly platform and tries to get as much support as possible when it comes to compatibility with mods. EET comes with tools and modder resources designed for easier EET support implementation, and I'm offering advices and help with any cross-platform related coding task for already released and upcoming BG:EE and BG2:EE mods.. Hopefully this approach will result in a respectable compatibility list once the mod become officially released, so that it could appeal to both mod makers and mod players.

 

Installation tips and notes on compatibility

- Big World Setup installation utility is preferable way to install mods for Windows users. It can automatically install huge selections of mods and you don't need to worry about install order and technical stuff.

- if you don't use Big World Setup manual installation of Big World Fixpack is needed for mods listed at the end of this post. Not only it fixes many known bugs but also patches some mods with EET compatibility related code.

- if you want to play with mods and don't use Big World Setup tool, it is highly recommended to check out the Big World Project installation PDF file for a reference of the installation order and compatibility between mods. Just keep in mind that in EET game some BG1 mods need to be installed on BG:EE previous to installing EET on BG2:EE.

- current compatibility between EET and other modifications are listed below.
- note that versions of modifications below those stated are not compatible.
- the compatibility list does not imply that the other modifications mentioned are compatible with each other. Make sure you understand the specific requirements of each modification by looking at their readmes before you go into hardcore mixing and matching.
- all modifications listed below support both EET Worldmap (when patched) and BP-BGT Worldmap. It's up to you which worldmap you will use.
 

1. Mods that can be installed on BG:EE previous to installing EET on BG2:EE

As a result of the conversion method explained in the readme, EET provides limited support for mods installed on BG:EE previous to installing EET on BG2:EE. Theoretically it could support almost any BG:EE mod with little to no work needed (for example adjusting BG1NPC Project to work with this method required just a few lines of code. Many mods don't need anything changed at all) as the mod resources are treated like vanilla content and patched "on the fly" during EET installation if needed. To ensure that BG:EE mods not intervene with BG2:EE portion of the game EET prevents starting the installation when unrecognised mod is detected.

 

This section can be treated as a temporary solution. Hopefully more and more mods will receive updates to support EET natively down the line, so they could be installed after EET on BG2:EE.

 

Here is a list of supported mods installed on BG:EE:

Compatibility with EET doesn't mean that mods are fully compatible with each other - refer to BWP PDF files, original readme files and forum discussions for compatibility details. For example Garrick : tales of a troubadour readme file states that it conflicts with Garrick's Infatuation and Tenya NPC and it is not recommended to install them together. Same readme file also mentions that the mod requires BG1 NPC Project installed before it.

 

Mods have been tested with versions mentioned in above list. It's unlikely that newer ones will break something, as the compatibility changes made to them during EET installation are minimal, if made at all. As long as the mod won't suddenly conflict with BG2:EE resources it should be still supported regardless of the chnges done to it. Although let us know if you notice any problems.

 

2. Mods that can be installed after EET main component on BG2:EE

This list, sorted in alphabetical order, contains BG2:EE mods that already have native EET support or don't need anything changed to work natively. Some of them are only available as a beta for now (older versions didn't have EET support), so keep that in mind.

3. Mods that can be installed after EET main component on BG2:EE but MUST BE PATCHED FIRST

For now you can't just install these mods on top of EET. You first need to download proper patch and extract it on top of the mod to add EET compatibility.

update: patches have been incorporated in Big World Fixpack, so use it before installing these mods (not needed if you're installing with Big World Setup).

 

The patch will become outdated as soon as the author updates a mod, so if this happens the patch should not be used and the mod will become not compatible. That is why we're trying to get in contact with every mod author to make these patches officially internalized. Hopefully this list will shrink over time.

This topic remains open. We would like to keep this list up to date, so please feel free to post about any mods that received an EET related update. Confirmations from authors about patches internalization and feedback regarding particular patches being obsolete due to mod update are very much welcomed too.


Edited by K4thos, 06 February 2017 - 01:47 PM.


#2 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 09:27 AM

Is anyone aware of work done for Northern Tales of the Swordcoast and if - yes - will it be part of the BGEE or BG2EE part of an EET installation?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#3 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 09:37 AM

Is it possible/recommended to use BWS already now to install a test-EET version? Will BWS identify and download the correct mod versions required for EET?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#4 K4thos

K4thos
  • Modders
  • 876 posts
  • Gender:Male

Posted 15 January 2016 - 10:36 AM

Is anyone aware of work done for Northern Tales of the Swordcoast and if - yes - will it be part of the BGEE or BG2EE part of an EET installation?

Like I've mentioned on SHS I'm working on updating NTotSC to work with both EET and BGT at the same time, so a version that hopefully will replace the one currently hosted on SHS. Native support, so installed after EET on BG2:EE or after BGT on BG2. Similar treatment as DSotSC, so modernized tp2 coding, EE engine related changes, cross-platform coding, internalization of all known bugfixes and major item and XP balancing overhaul. Although it's uncertain if this particular update will be even released because author of the original mod (Aurelinus) was not very happy with Sir Billy Bob's conversion to BGT (IIRC he once said that if he would get another chance at the time he would forbid the release of BGT version because it's not faithful enough to his work), so maybe he will be also against this one. I will try to contact him and check his stance.

When it comes to DSotSC the problem didn't exist because I've received a blessing from the original author - CuChoinneach.

 

Is it possible/recommended to use BWS already now to install a test-EET version? Will BWS identify and download the correct mod versions required for EET?

unfortunately no. You can do some hacking to enable it but it will work correctly only on mods installed on BG:EE. BG2 ones needs to be installed manually for now. BWS would install incorrect versions (for example you had wrong version of Tower of Deception in your last weidu.log that you posted on SHS - the newest one is 4.0), and it can't implement patches mentioned in this topic for now. Before requesting help from BWS guys regarding patches implementation in similar fashion to Big World Fixpack let's find out if mod authors are actually interested in internalizing these patches themselves or if some of them are against EET support altogether. I also need to check if Big World Fixpack itself conflicts with current patches because I used original releases to prepare them rather than mods patched with BWF.

So yeah, installing many mods with beta EET is a nightmare. But when EET will be released officially it will be fully supported by Big World Setup.


Edited by K4thos, 15 January 2016 - 10:37 AM.


#5 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 11:05 AM

 

Is anyone aware of work done for Northern Tales of the Swordcoast and if - yes - will it be part of the BGEE or BG2EE part of an EET installation?

Like I've mentioned on SHS I'm working on updating NTotSC to work with both EET and BGT at the same time, so a version that hopefully will replace the one currently hosted on SHS. Native support, so installed after EET on BG2:EE or after BGT on BG2. Similar treatment as DSotSC, so modernized tp2 coding, EE engine related changes, cross-platform coding, internalization of all known bugfixes and major item and XP balancing overhaul. Although it's uncertain if this particular update will be even released because author of the original mod (Aurelinus) was not very happy with Sir Billy Bob's conversion to BGT (IIRC he once said that if he would get another chance at the time he would forbid the release of BGT version because it's not faithful enough to his work), so maybe he will be also against this one. I will try to contact him and check his stance.

When it comes to DSotSC the problem didn't exist because I've received a blessing from the original author - CuChoinneach.

 

Is it possible/recommended to use BWS already now to install a test-EET version? Will BWS identify and download the correct mod versions required for EET?

unfortunately no. You can do some hacking to enable it but it will work correctly only on mods installed on BG:EE. BG2 ones needs to be installed manually for now. BWS would install incorrect versions (for example you had wrong version of Tower of Deception in your last weidu.log that you posted on SHS - the newest one is 4.0), and it can't implement patches mentioned in this topic for now. Before requesting help from BWS guys regarding patches implementation in similar fashion to Big World Fixpack let's find out if mod authors are actually interested in internalizing these patches themselves or if some of them are against EET support altogether. I also need to check if Big World Fixpack itself conflicts with current patches because I used original releases to prepare them rather than mods patched with BWF.

So yeah, installing many mods with beta EET is a nightmare. But when EET will be released officially it will be fully supported by Big World Setup.

 

Thank you for both answers - I will thus be able to proceed as follows

Make a BGEE install with your listed mods - it contains everything to proceed with Sandrah in this part (except Northern Tales)

I will install EET

I will install the BG2EE mods from your list I need

I will install my homemade version of Aurora for further testing

I will install Sandrah on top of all (I will regularly install and de-install her as I progress)

I will install NTotSC whenever a useable version becomes available and integrate it (until then I will work with some homemade extract that is based on the assumption that NTotSC will be contentswise equivalent to BGT)

 

I keep my fingers crossed for your success on NTotSC - without Ghotal and the Fields of Death I will be stuck before the BG2 part can even start.

 

Currently I am content that Sandrah's interaction with all other mods is mostly same as in BGT, the major issue is to identify and replace former BGT resources used by suitable EE/EET ones (creatures, items, and standard scripts) or develop custom ones to replace the missing ones.


Edited by Roxanne, 15 January 2016 - 11:09 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#6 agb1

agb1
  • Modders
  • 410 posts
  • Gender:Male

Posted 15 January 2016 - 01:29 PM

K4thos, congratulations on the new forum. I plan to update BWS this weekend to install the EET mods that are currently available. Have you considered using patching for the BG2 mods instead of replacement files, as is done by the BiG World Fixpack?

Edit: I see you answered this already. Please disregard.

Edited by agb1, 15 January 2016 - 01:36 PM.

BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#7 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 02:15 PM

In the installation instruction of the first post you provide an order to install BGEE mods.

The 2. Mods that can be installed after EET on BG2:EE are just in alphabetical order - does the sequence not matter for them?


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#8 agb1

agb1
  • Modders
  • 410 posts
  • Gender:Male

Posted 15 January 2016 - 02:28 PM

Order does matter, but not for EET compatibility, just for final state of the game. I think you should follow the same order you would for BGT.

BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#9 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 02:33 PM

Followed the BGEE install as per your post.

Now I receive EET error - Cannot install due to Valerie - I checked twice that I have version 1.1 for BGEE according to your list. EET version was just downloaded from master zip.


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#10 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 02:38 PM

Order does matter, but not for EET compatibility, just for final state of the game. I think you should follow the same order you would for BGT.

???This is what I would have guessed BUT what about mods like Grey Clan or DSotSC?

I probably try roughly

- Ascension

- big contents mods

- npc mods

- worldmap

- I will leave out spells/items/portraits and such stuff anyway for the time being


Edited by Roxanne, 16 January 2016 - 03:08 AM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#11 agb1

agb1
  • Modders
  • 410 posts
  • Gender:Male

Posted 15 January 2016 - 02:42 PM

That looks reasonable.

BiG World Fixpack (community collection of mod fixes and compatibility patches, with user-friendly cross-platform script)

 

BiG World Setup (tool to automate best-practice installation of Infinity Engine mods on Windows, with conflict analysis)

Latest version:    https://bitbucket.or.../get/master.zip


#12 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 02:47 PM

In the installation instruction of the first post you provide an order to install BGEE mods.

The 2. Mods that can be installed after EET on BG2:EE are just in alphabetical order - does the sequence not matter for them?


Edited by Roxanne, 15 January 2016 - 02:48 PM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#13 Roxanne

Roxanne
  • Modders
  • 1255 posts
  • Gender:Not Telling

Posted 15 January 2016 - 02:48 PM

Followed the BGEE install as per your post.

Now I receive EET error - Cannot install due to Valerie - I checked twice that I have version 1.1 for BGEE according to your list. EET version was just downloaded from master zip.

This is BGEE Weidu log

~VALERIE\VALERIE.TP2~ #0 #0 // Valerie NPC Mod for BG1 Tutu: v1.1

This is EET compatibility.tbl

VALERIE 0            //Valerie NPC Mod for BG1 Tutu


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#14 K4thos

K4thos
  • Modders
  • 876 posts
  • Gender:Male

Posted 15 January 2016 - 02:51 PM

The 2. Mods that can be installed after EET on BG2:EE are just in alphabetical order - does the sequence not matter for them?

To not confuse people I will sort BG:EE mods in alphabetical order. Of course installation order does matter. It's even mentioned in the first post.

 

I will check that Valerie mod, wait a sec.



#15 White Agnus

White Agnus
  • Modders
  • 74 posts
  • Gender:Male

Posted 15 January 2016 - 03:00 PM

Hmm, have installed EET today with Valerie preinstalled on BG1EE...

Maybe the backslash in the weidu.log prevents the installation, here is my weidu.log entry:
~VALERIE/VALERIE.TP2~ #0 #0 // Valerie NPC Mod for BG1 Tutu: v1.1 BWP Fix



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users