Jump to content


Photo

SoD 2.3 and BG2EE Best Install Advice?


4 replies to this topic

#1 Aryn

Aryn
  • Members
  • 39 posts

Posted 21 July 2018 - 07:58 PM

I havent been keeping up with all of the ins and outs of the mod community. I have been trying to do a fresh install on my MacBook Pro with a few mods including EET, SR, DR, SCS, etc. I have been runn8ng into several errors. It has been suggested the reason is because the two games are out of sync or 2.5 is causing issues.

So, should I be using beta or retail versions? Will it work if I have SoD 2.3 and BG2EE 2.5? Just trying to figure out the best way to proceed with the games in their current release states.

#2 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6625 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 22 July 2018 - 01:23 AM

Well, you come at an opportune time to find out, as the last EET beta was released just yesterday... well anyways, so there is no advice to be given yet.


Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#3 K4thos

K4thos
  • Modders
  • 1146 posts
  • Gender:Male

Posted 22 July 2018 - 01:36 AM

From what I see there are problems with SCS on patch 2.5: https://forums.beamd...#Comment_971562


Edited by K4thos, 22 July 2018 - 04:36 AM.


#4 Aryn

Aryn
  • Members
  • 39 posts

Posted 22 July 2018 - 11:59 AM

Should I be using the beta or retail releases of SoD and BG2EE?



#5 K4thos

K4thos
  • Modders
  • 1146 posts
  • Gender:Male

Posted 22 July 2018 - 12:04 PM

retail, never use betas. Quote from readme:

 

Core EET component requires "clean" BG2:EE installation with latest patch (currently v2.5.16.6). Translations and voice-overs are of course allowed but installing other (especially larger) mods that changes DLG and BCS files, before EET, may cause problems with later patching, so it's better to keep the installation as clean as possible.

The BG:EE + Siege of Dragonspear installation with latest patch (currently v2.3.67.3) should be either "clean" installation or with any combination of mods mentioned in section 1 of this list.

If you use Steam or GOG version of Siege of Dragonspear than you first need to use modmerge tool in your BG:EE + SoD directory. This utility released by Beamdog merges your Steam/GOG zip based DLC into something WeiDU can use. It only affects above mentioned platforms - you don't need to use it if you bought the game on Beamdog store.

SoD installation contains all BG:EE resources, so if you have expansion installed in separate directory, you should point to it during EET installation, rather than BG:EE.

 

 





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users