Jump to content


Photo

Windows builds are back!


37 replies to this topic

#31 lynx

lynx
  • Modders
  • 2990 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 23 October 2016 - 12:40 AM

oh, I think I forgot to mention earlier: scrolling speed is controllable via the options screen. If pst doesn't have it in there, then by editing gem-torment.ini in the game dir.


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#32 Theodor

Theodor
  • Members
  • 3 posts

Posted 13 September 2017 - 09:20 PM

Tried that new version of gemrb and had disappointed.

 

It won't start on 32 bit windows, this is for old very old game, that runs on the old pc as well, what a point make it only for 64 bit windows?



#33 lynx

lynx
  • Modders
  • 2990 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 13 September 2017 - 11:31 PM

What makes you think it's a 64-bit build? oO


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#34 Theodor

Theodor
  • Members
  • 3 posts

Posted 14 September 2017 - 01:58 PM

Said it is not a valid Win32 application.



#35 lynx

lynx
  • Modders
  • 2990 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 15 September 2017 - 01:08 AM

Even if what it says is true, it's not intentional. The buildbot uses a bunch of 32-bit dependencies and doesn't specify a 64-bit compiler, so it'd be really odd and wouldn't work at all. I'm pretty sure it also worked with 32-bit wine when I was setting it up.

 

Anyway, I've added a debug print to display the target and after some fiiddling, appveyor confirms it is doing 32-bit builds.

 

So the error is misleading. Something else is wrong. Do you perchance have a compiler set up?


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#36 Avenger

Avenger
  • Modders
  • 3710 posts
  • Gender:Male
  • Location:Hungary

Posted 16 September 2017 - 01:12 AM

I think the same message is displayed, If the file is corrupted in some way.



#37 lynx

lynx
  • Modders
  • 2990 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 16 September 2017 - 12:22 PM

I retried with wine. All I had to do was install the ms visual runtime 2013, since wine didn't implement one of the functions yet. You probably already have it installed.

 

Then I just set the plugins and cache path in the sample config and it ran far before realising I didn't point it to any game. So all is fine. I'll adjust the build bot so the path part is not necessary in future builds.


Edited by lynx, 16 September 2017 - 01:20 PM.

GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#38 lynx

lynx
  • Modders
  • 2990 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 17 September 2017 - 12:40 AM

Anyway, I've added a short checklist on how to make the buildbot binaries run:

http://www.gemrb.org...install:windows


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...



Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users