Jump to content


Photo

pathfinding in EET


4 replies to this topic

#1 Ikki

Ikki
  • Members
  • 47 posts

Posted 11 July 2017 - 12:16 AM

Is it possible to change the pathfinding use in EET for the one use in SOD ( or even better for the one use in BG2classic )



#2 K4thos

K4thos
  • Modders
  • 1057 posts
  • Gender:Male

Posted 11 July 2017 - 02:39 AM

pathfinding is hardcoded in engine. SoD uses the same engine version as BG2:EE, so it should work the same way (give some examples if it's not the case since it may be related to something else rather than pathfinding, for example different CRE personal space).

 

Patch 2.4 for BG2:EE will bring some improvements to pathfinding:

https://support.bald...om/issues/24125

https://support.bald...om/issues/24126

https://support.bald...om/issues/24121

 

And there are some issues reported that are not confirmed fixed for next release yet:

https://support.bald...om/issues/24122

https://support.bald...om/issues/22309

https://support.bald...om/issues/22239



#3 Ikki

Ikki
  • Members
  • 47 posts

Posted 11 July 2017 - 02:59 AM

Yes, those are exactly the bugs I experience in game, but it's more problematic in EET than in SOD classic.

 

If they are fixed in the next patch it would be great, but this should have been fixed long ago



#4 K4thos

K4thos
  • Modders
  • 1057 posts
  • Gender:Male

Posted 11 July 2017 - 06:27 AM

but it's more problematic in EET than in SOD classic.

I need detailed example for this claim. There are ways to test if this is really the case (starting from changing engine_mode setting in engine.lua to use BG:EE mode and, if that doesn't help, checking personal_space value assigned to problematic creature via animation INI files). So a save file with description like in the above mentioned reports in Beamdog redmine would really help.


Edited by K4thos, 11 July 2017 - 06:28 AM.


#5 Ikki

Ikki
  • Members
  • 47 posts

Posted 13 July 2017 - 12:17 AM

Thank Kathos,

it not so easy to reproduced, because it's totaly random : the worse pathfinding issue is for me, teammate that "magnetise" themself together during battle and can not hit the ennemy

 

What i tried so far

- turning "engine_mode = 0" : that work the same as with BG2EE engine

- trying to desactivate "Enhanced Path Search"
- trying to desactivate "Enhanced Path Finding"

 

by the way is it still possible to desactivate those options with the baldur.ini ? because i don't see a change in game

 

i added the lines in baldur.lua now


Edited by Ikki, 13 July 2017 - 03:15 AM.




Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users