Jump to content

Ridiculous Promenade Bug

5 replies to this topic

#1 Guest_Icarian_*

  • Guests

Posted 10 May 2009 - 01:39 PM

Fresh installation, perfect order, no conflicts.

I finish the dungeon, and decide to clear the group at the Den of Seven Vales before continuing down to the circus and Ribald. I try to rest, but no dice. I'm there talking to Patricia, when suddenly Kivan appears out of nowhere, screams something nonsensical (along the lines of "I knew I should have expected this from a creature like you!") and dimensiondoor-es out.

He doesn't appear in front of the circus tent when I go back out, nor was I able to find him anywhere in the promenade, including the aforementioned inn. I guess he just thought it would be a good idea to track me down all the way from Shilmista just to call me a "creature."

I swear, elves have the weirdest sense of humor ever.

#2 Guest_Icarian_*

  • Guests

Posted 10 May 2009 - 02:54 PM

I managed to get him back through the CreateCreature console command, but the join dialogue was bugged (he used NPC lines from the Maevar quest if I'm not mistaken).

Quite entertaining.

#3 Ankhesenpaaten


    Fate Unknown

  • Members
  • 519 posts
  • Gender:Female
  • Location:Heartland USA

Posted 10 May 2009 - 05:22 PM

I've had this happen to me too. I just went to the Mithrist Inn to buy some dyes (Rupert the Dye Merchant) and Kivan used the Harper guy's line dimension doored out. I thought it was weird. Why couldn't he just wait outside the door of wherever you are? Anyway it isn't too bad as you can just reload the autosave after leaving Irenicus' dungeon.

#4 Leomar

  • Modders
  • 405 posts
  • Gender:Male
  • Location:Germany

Posted 12 May 2009 - 01:17 AM

Hmmm, this issue was reported a long time ago.

Here and here.

But it were not found out, what is causing this. A new install solved the problem or Ankhesenpaaten better solution to reload the autosave...

Greetings Leomar

#5 lynx

  • Modders
  • 3156 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 27 July 2016 - 12:53 PM

FIX below.


In case anyone else gets bit by this. The problem is blatantly obvious in gemrb. The particular response is governed by a simple local variable, not used anywhere else, so it was simple to track down.


So which one of the three is true on spawn? HPPercentLT and quite obviously — the CRE file has 40/44 HP.


(the real question is if some versions of the engine did or didn't heal creatures on spawn: testing in tob via script or cheats shows no heal — htf could this have ever worked?)


Update: the issue isn't obviously visible in the original, since even if you dismiss him, he just immediately escapes, so the block doesn't get a chance to run. If the preceding movement blocks that start the dialog were removed, the issue would be clear.

Edited by lynx, 27 July 2016 - 02:40 PM.

GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Play android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#6 jastey

  • Gibberlings
  • 7547 posts
  • Gender:Female

Posted 28 August 2018 - 08:04 PM

This should be fixed in v16, the cre now has full HP. Thank you for the reports!

Reply to this topic


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users