Jump to content


Photo

Geomantic Sorcerer Kit


207 replies to this topic

#196 Ishad Nha

Ishad Nha
  • Modders
  • 465 posts
  • Gender:Male

Posted 10 February 2016 - 08:15 PM

The Geomantic Sorceror kit was inspired by Constant Gaw's Druidic Sorceror kit. I am presently trying to make that suitable for starting at any level, not just level 8. Next I will want to port it to the EE world.

None of the Sorceror kits can be dual-classed. What you might be able to do is have an imaginary first class of your own choosing.
If attempting a Thief -> Sorceror dual class:
Game plan is to create the PC as a Sorceror. Now he won't have access to the Thieving buttons. You can alter Keymap.ini to give hot keys to the explicit abilities concerned:
Thieving=K
Stealth=S
Trap Detection=N
I tested this and it works in actual practice.*
Set Snare ability can be added as: SPCL412 Set Snare.
Backstabbing will be problematic, it could be added as an ability.
Some ability to use Thief items can be given by SPCL915 HLA: Use Any Item. I have not tested this yet.
*(This can be extended to other classes too:
Turn Undead=T
Battle Song=B)

Abilities with a class level variable could be a hassle. Notional classes give no levels in the classes concerned, maybe replace the level variable with a fixed number. The notional, imaginary, dual-classing happens at a fixed imaginary level in the first class. If starting BG2, a Thief should be at level 8, so the fixed number would be 8. So you could award the Thief with ~70,000 imaginary xp as a Thief and 19,000 actual xp as a Sorceror. You could use a script to set his level to 4.

Here, explicit innate abilities means abilities that must be used before they take effect, like those found in the Innate Abilities menu. Implicit abilities are always in effect.



#197 Ishad Nha

Ishad Nha
  • Modders
  • 465 posts
  • Gender:Male

Posted 27 February 2016 - 05:30 PM

Party is now in Hell, the Geomantic Sorcerer has been working well. Druids are second-rate at everything, the presence of the GS means that I don't need one.

So far the GS has not enough XP to achieve any HLAs, that will come in Throne of Bhaal.

 

I had to alter the Harper Pin so that Neutral Good GS Jaheira could wear one, that was easy to do in Near Infinity.


Edited by Ishad Nha, 27 February 2016 - 05:34 PM.


#198 Graoumf

Graoumf
  • Members
  • 256 posts
  • Gender:Male
  • Location:France

Posted 23 July 2016 - 05:21 AM

Hello,

 

It seems Ishad Nha posted a EE compatible version of Geomantic Sorcerer Kit on Sorceror's place at the enf of December.

This version doesn't work for the french translation because HANDLE_CHARSETS are not used.

 

Is it possible to update the version in order that others languages works and upload it on G3 download site?



#199 Ishad Nha

Ishad Nha
  • Modders
  • 465 posts
  • Gender:Male

Posted 23 July 2016 - 05:41 PM

I don't speak French all that well, so the problem was not spotted by me.

I know nothing about HANDLE_CHARSETS or how to properly use this function, I will need to look into this...



#200 deratiseur

deratiseur
  • Modders
  • 125 posts
  • Gender:Male
  • Location:GAP, Hautes Alpes, France

Posted 11 August 2016 - 08:31 PM

Done.

 

For the french EE version, the archive is here.


My kits pack in french and english : Deratiseur's Unused Kits Pack v14  for TOB / BGT / BGEE / BG2EE / IWDEE for PC and MAC OS-X

My french quest/shop mod : L'ogre et le gnome, une histoire de bleu v2 for BG2 / BGT / BG2EE


#201 Irithylstarym

Irithylstarym
  • Members
  • 11 posts

Posted 17 April 2017 - 10:40 AM

Heya guys, I just installed the mod today, using the most recent version of it (http://www.sorcerers...ceror-kit.78997), but sadly when creating a new character this kit doesnt appear and when I choose it was the kit for sorcerer in eekeeper, my character in game appears as a basic sorcerer and levels as one. Can you please help me sort this out?



#202 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6204 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 17 April 2017 - 11:44 AM

Heya guys, I just installed the mod today, using the most recent version of it (http://www.sorcerers...ceror-kit.78997), but sadly when creating a new character this kit doesnt appear and when I choose it was the kit for sorcerer in eekeeper, my character in game appears as a basic sorcerer and levels as one. Can you please help me sort this out?

This mod has not been updated to the v2.3  games, so you need to utilize the old style of making the class, aka you need to go with the instructions and not ShadowEEkeeper's way. And the game probably needs to be the IWDEE, not a BG2(EE).

If it were a v2.3. it would include the ability to pick up the kit at the character creation, which needs a bit of work ... but it's not. As the IWDEE is/was Enhanced Edition v1.4. Also the fl#add_kit_ee.tpa is from v1.0.5, while the newest is v1.1.3 which should be included in the weidu.exe itself... though I haven't ever used it from there.


Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#203 Irithylstarym

Irithylstarym
  • Members
  • 11 posts

Posted 17 April 2017 - 12:14 PM

Thank you very much for your quick reply! What do you mean by V2.3 games? The version I downloaded was uploaded on the 2017-01-06. The Geomantic Sorcerer was originally made for bg2, according to the uploader this version was updated specifically for bgee, bg2ee and iwdee. :( 



#204 Irithylstarym

Irithylstarym
  • Members
  • 11 posts

Posted 17 April 2017 - 12:16 PM

Also how do I integrate the files from v1.1.3? Bear in mind I'm a noob guy who just downloads the files and installs them :p



#205 Irithylstarym

Irithylstarym
  • Members
  • 11 posts

Posted 17 April 2017 - 12:19 PM

It worked!!!! I followed the directions regarding the tpa from v1.1.3! Thank you so much <3



#206 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6204 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 17 April 2017 - 12:34 PM

Thank you very much for your quick reply! What do you mean by V2.3 games?

You'll notice the double dot's there in my reply, it means v2.3.67.2 or later ... as in ...67.3 or what ever it's todays.

Yeah, you just needed to download the .tpa -file, extract it to the mods internal file structure where the original was and overwrite that, and then reinstall again ... and that should do some of the work.. not that that guarantees that the mod is then able to work, but...


Edited by Jarno Mikkola, 17 April 2017 - 12:34 PM.

Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#207 reallyhairydave

reallyhairydave
  • Members
  • 1 posts

Posted 31 August 2017 - 05:00 AM

Hi there, I've just completed a fresh install of BWP for EE and was doing my usual of adding a few mods I like that aren't in the pack, this is the only one I've had an issue with and it's one that is stumping me as all the others haven't run into this one, here's the log. I would also like to say this is one of my favorite kits and thank all of you who keep it maintained :)

 

WeiDU v 24200 Log

 C:\Games\Steam\steamapps\common\Baldur's Gate II Enhanced Edition\setup-druidsor.exe
[.\chitin.key] loaded, 1172566 bytes
[.\chitin.key] 282 BIFFs, 83161 resources
[./Desktop.ini] loaded, 190 bytes
[.\engine.lua] loaded, 109 bytes
[.\weidu.conf] loaded, 16 bytes
[.\lang\en_us\dialog.tlk] 367888 string entries

Choose your language:
 0 [English]
 1 [Francais (Translation by zooloo of the D'Oghmatiques)]

 

Using Language [Francais (Translation by zooloo of the D'Oghmatiques)]
[Francais (Translation by zooloo of the D'Oghmatiques)] has 4 top-level TRA files
ERROR: problem parsing TP file [DRUIDSOR/SETUP-DRUIDSOR.TP2]: Sys_error("languages/english: Permission denied")

FATAL ERROR: Sys_error("languages/english: Permission denied")

        WeiDU Timings
parsing .log files               0.000
loading files                    0.000
Parsing TP2 files                0.016
unmarshal KEY                    0.047
stuff not covered elsewhere      0.297
unmarshal TLK                    1.328
TOTAL                            1.688

 

Edit* Yes I know I chose French for this example however it throws out the same result either way, I was just seeing if it was just the English part that had a problem


Edited by reallyhairydave, 31 August 2017 - 05:02 AM.


#208 Ishad Nha

Ishad Nha
  • Modders
  • 465 posts
  • Gender:Male

Posted 03 September 2017 - 05:43 PM

Your PC seems to be a total control freak:
"languages/english: Permission denied"

"[Francais (Translation by zooloo of the D'Oghmatiques)] has 4 top-level TRA files"
That is dead wrong, there is only the one Tra file in the folder...

Check the English and French sub folders of the Languages folder. There should only be one file in each.
Right-click on each file and click on the Properties line of the context menu.
Check that the file does not need to be Unblocked because it has come from another PC.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users