Jump to content

Photo

SR V4 Open Beta (last update 25 October 2018)


  • This topic is locked This topic is locked
1270 replies to this topic

#1261 Jarno Mikkola

Jarno Mikkola

    The Imp

  • Modders
  • 6823 posts
  • Gender:Male
  • Location:The town where the dead haven't keeled over, yet. In Finland.

Posted 05 April 2018 - 05:43 AM

Antimagic attacks DO NOT penetrate invisibility.

Do you know why this wasn't a problem in vanilla. Cause the higher level mages aka Liches were "immune to invisibility", cause they never bothered to cast spells they were "immune towards", so most weren't that big of a deal. But then entered the SCS AI that doesn't so much cheat as not respect the original rules where, when a creature is immune to a spell level, they are immune to the entire level, so they don't bother to cast those spells, even the protections spells of those levels. This also reduces the their attack power, but mostly... it just locks the player to the you need a level 8th spell to remove the level 9th spell protection(spell trap) so you can then remove the level 1-4 invisibility, so that you can then break that with a level 5th spell(true sight) and then another level 5 spell(breach) to be able to damage them in melee. Well the Simulacrum ...while you still have the actual lich is casting Time Stops, summoning Planetars and what else, that has the same protections, or worse, they got a contingency that reverts all that work back cause they took 1 point of hit point damage.
Or just have a 9th level mage spell and cast a Spell Strike that kills the lich cause iut has no defenses... well if it has no Simulacrum/projections etc clones.
Welcome to the sanity, you are free to search for the limit, it's out there, we drew it in the sand.
Here's how to install all the ... mods you ever really could want to Infinity Engine games. I removed the stable word from there as Roxanne began to add BS mods that are likely to break compatibility from the BWS.

#1262 geg_Ma3gau

geg_Ma3gau
  • Members
  • 157 posts

Posted 05 April 2018 - 07:20 AM

Why do i get two diffirent spell revision versions? The last time i installed, Flesh to Stone had -5 save. Now it has -4 and it slows for three rounds beforehand. I have no idea which one is up to date.



#1263 Serg BlackStrider

Serg BlackStrider
  • Members
  • 42 posts
  • Gender:Male
  • Location:Minsk, Belarus

Posted 05 April 2018 - 07:58 AM

Why do i get two diffirent spell revision versions? The last time i installed, Flesh to Stone had -5 save. Now it has -4 and it slows for three rounds beforehand. I have no idea which one is up to date.

I don't know 'why' in your case but even though the latest version is @Kreso's beta 15, I still use beta 14 and within it there are '-4 save and Slow for three rounds beforehand'.



#1264 geg_Ma3gau

geg_Ma3gau
  • Members
  • 157 posts

Posted 05 April 2018 - 08:17 AM

Apparently i was using SRv3. And what we have today is SRv4.



#1265 malax83

malax83
  • Members
  • 14 posts

Posted 15 May 2018 - 05:09 AM

 

You also might like our Low Magic World mod, which I think we released since you were gone...

(Okay I'm done advertising.)

 

#500 components is really interessant,

 

PS : Please, somebody can answer to my last message, thanks

 

 

Hello

 

Long time passed since i ve installed a clean version with SR v4.0 and some basics component with Big World. I m starting the game now but i m asking if i can add "low magic world" without installing my french translation. I didn t find the correct topic for loow magic world so i m sorry if i post in the wrong place. I suppose it bugs cause i ve installed french translation.. What do you think about this ? Thanks

 

[C:\Users\SM1983\Beamdog Library\00783\setup-low_magic.exe] WeiDU version 24400
Using Language [English]

[low_magic/language/en_US/setup.tra] PARSE ERROR at line 441 column 1-0
Near Text:
        syntax error

[low_magic/language/en_US/setup.tra]  ERROR at line 441 column 1-0
Near Text:
        Parsing.Parse_error
ERROR: parsing [low_magic/language/en_US/setup.tra]: Parsing.Parse_error
ERROR: problem parsing TP file [LOW_MAGIC/LOW_MAGIC.TP2]: Parsing.Parse_error

FATAL ERROR: Parsing.Parse_error

Press ENTER to exit.

 


Also, i would like to know if the "encounters when your group" has a rest is balanced ? Which mod can i install if this seems to easy to rest then attack ? Is a mod with a cumulative higher chance to encounter monsters exist ?

 

PS : i already talk about infinity rest in this topic : http://gibberlings3....c=29283&hl=rest

It seems nothing exist yet.. it s pretty annoying
 


Edited by malax83, 15 May 2018 - 06:12 AM.


#1266 subtledoctor

subtledoctor
  • Modders
  • 2831 posts
  • Gender:Male

Posted 15 May 2018 - 09:20 AM

i would like to know if the "encounters when your group" has a rest is balanced ? Which mod can i install if this seems to easy to rest then attack ? Is a mod with a cumulative higher chance to encounter monsters exist ? 


Cumulative increase is not possible AFAIK. But Tweaks Anthology has a component to increase chance of enemy spawns, thus making resting more difficult.

Faiths & Powers: Spell spheres and kit pack for priests and paladins
Might & Guile: Tweaks and kits for warriors and rogues
Scales of Balance: Game tweaks and rule overhauls
NPC_EE: More options for NPCs in BGEE, SoD, & BG2EE


#1267 malax83

malax83
  • Members
  • 14 posts

Posted 15 May 2018 - 10:55 AM

 

i would like to know if the "encounters when your group" has a rest is balanced ? Which mod can i install if this seems to easy to rest then attack ? Is a mod with a cumulative higher chance to encounter monsters exist ? 


Cumulative increase is not possible AFAIK. But Tweaks Anthology has a component to increase chance of enemy spawns, thus making resting more difficult.

 

 

Yes it seems not possible to add a cumulative chance to encounters... I didn t play BG2 since a long time, anyway, I would be a good tester with my average experience of ADD and in a less measure BG : i m running BG2:EE with very hard difficulty and basic change of Big World and i m trying to make each region with only one rest. Do you think it s possible ? Maybe some regions are harder and could be achieved with a little bit more rest ? Then i ll send you how many rest i ve make per region (even if nothing is really interested...). 

 

I notice when Jaheira throw "sunscorch", it deals damage as an old spell but when it s my main character, sunscorch is nerfed as SR do (1d8+1/lvl). SO for now i only got one sunscorch spell for Jaheira.

 

Then i feel the damage spell scaling too fast... Magic projectile make 1D4  then the fireball do 1D6 to all creature with only two levels inbetween, .... Probably everyone has its on opinion but mages has always been very strong. For now i m also restricted to learn one "fireball spell" per mage. I don t think i would install : Component #200: No Spell Level Scaling cause it s little bit "all or nothing" but i would appreciate a smooth scale of damage.

 

Some part of low magics world looks fine to fit to BG as : Component #500: Weaponized Wands and could be added to the basic of BG

 

PS : for now low magic world doesn t work on my setup....

 

Regards


Edited by malax83, 15 May 2018 - 11:01 AM.


#1268 malax83

malax83
  • Members
  • 14 posts

Posted 19 May 2018 - 10:35 PM

Hello,
In order to install low magic mod, i added "~ ~" to the last line of the setup.tra file in the language\en_US directory. Then the installation goes on and i achieve to install 4 componnents but the installation fails to install one of the componnent i would really like... ::: Component #500: Weaponized Wands

could you help me to resolve this one please ?

Here s the link BEDUG file :

http://s000.tinyuplo...649702607873405

maybe it s cause i installed Kivan...



#1269 subtledoctor

subtledoctor
  • Modders
  • 2831 posts
  • Gender:Male

Posted 20 May 2018 - 04:34 AM

I installed and I'm playing with the low magic mod on BGEE, so I can't reproduce.

Please direct any discussion of that mod to its own location, here:
https://forums.beamd...ee-iwdee#latest

Faiths & Powers: Spell spheres and kit pack for priests and paladins
Might & Guile: Tweaks and kits for warriors and rogues
Scales of Balance: Game tweaks and rule overhauls
NPC_EE: More options for NPCs in BGEE, SoD, & BG2EE


#1270 Balderson

Balderson
  • Members
  • 1 posts

Posted 22 May 2018 - 12:01 PM

Hello, and thanks for working on this.
I just made an account in order to ask about this problem with installing this Beta of SR:
 
Yesterday, i made a clean install of BGEE from the old separate Beamdog launcher into C:\Users\accountname\Baldur's Gate\Baldur's Gate Enhanced Edition\Data\00766 - so that should be fine, right?
BUT when i try installing SR on top of that, i do not get very far before i get an ERROR message.
 
This is the end of the DEBUG file(i couldn't find any way to attatch or upload the file):

Spoiler


I hope it is okay to post this here. I just can't see what could be wrong with a clean install. Is this version not confirmed to work with the 2.3 patch?

 

 

EDIT: Whoops, i just found subtledoctor's solution in this post http://gibberlings3....ic=28817&page=2 . Thanks!


Edited by Balderson, 31 May 2018 - 02:00 PM.
added spoiler tags


#1271 Mike1072

Mike1072
  • Gibberling Poobah
  • 2521 posts
  • Gender:Male
  • Location:Canada

Posted 25 October 2018 - 08:09 PM

With the release of SR V4 Beta 16, I'm closing this discussion. Please leave comments for SRv4b16 in this thread.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users