Jump to content

Photo

Item Revisions and ID:EE


2 replies to this topic

#1 zwadek

zwadek
  • Members
  • 6 posts

Posted 02 May 2017 - 04:23 AM

I was wondering - has anyone tried to install IR on ID:EE? Is it somehow possible? I would love to try ID:EE but playing without IR and SR feels just wrong :) any suggestions?



#2 subtledoctor

subtledoctor
  • Modders
  • 2751 posts
  • Gender:Male

Posted 02 May 2017 - 07:35 AM

I'm playing with both IR and SR on IWDEE.

IR is easier to install, but has more issues in-game: IR uses static lists of resources to be modified, so the main issues are that potions aren't affected at all, and armor modifications are inconsistent. Oh, and the shield modifications and "thieves can use wands" do not install at all. I just deal with vanilla potions and shields, it's not the end of the world. For armor, I use my own YARAS mod instead of IR.

On reflection, this means that IR doesn't actually have very much effect on IWD; importantly, the basic weapon changes DO work, as well as stuff like "more weapon usable for backstabbing" and "offhand penalties for heavy weapons" etc.

SR is a tougher nut to crack, because SR adds several IWD spells into the game, which already exist in IWD (duh). Furthermore, SR adds spells with file names which are free in BG but not free in IWD (because IWD has more spells at each level than BG/BG2), thus overwriting vanilla IWD spells that we want to keep.

I've created an edited version of SR that solves most issues. If and when I get the chance, I can post that for you to use.

Edited by subtledoctor, 02 May 2017 - 06:29 PM.

Faiths & Powers: Spell spheres and kit pack for priests and paladins
Might & Guile: Tweaks and kits for warriors and rogues
Scales of Balance: Game tweaks and rule overhauls
NPC_EE: More options for NPCs in BGEE, SoD, & BG2EE


#3 zwadek

zwadek
  • Members
  • 6 posts

Posted 04 May 2017 - 01:21 AM

Wow, theese are really wonderful news my fellow adventurer, I would be more than happy to try your version of SR, thanks in advance :)

 

edit:

 

May I ask how did you managed to run an instaler? because when I try to instal IR i get an error: "this component may only be installed on BG:ToB, BGT, Tutu, BGEE, or BG2EE" for the main component, and "this component is not compatible with your game" for the other components


Edited by zwadek, 04 May 2017 - 11:15 AM.




Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users