Jump to content

Photo

EET 1.0 Release Candidate 11 up on GitHub


1065 replies to this topic

#16 Ulb

Ulb
  • Members
  • 188 posts
  • Gender:Male

Posted 27 July 2016 - 03:44 PM

Update 2: OK, I'v looked into the tp2 file and it turns out the file EET checks for in the BG:EE folder is not where it is supposed to be.

 

EET wants SoDAreas.bif to be in the /data/ folder but apparently modmerge puts the file into a folger called /sod-dlc/ instead. I'm not to sure what to do as /sod-dlc/ holds a number of duplicate files form /data/ so even if I moved/copied the file over into data the installation would probably still run into some issues.



#17 CrevsDaak

CrevsDaak

    imma lil orc now duh duh

  • Modders
  • 166 posts
  • Gender:Male
  • Location:Bs. As., Argentina

Posted 27 July 2016 - 04:40 PM

Hey! Congrats on the release!  :thumbsup:



#18 Mike1072

Mike1072
  • Gibberling Poobah
  • 2531 posts
  • Gender:Male
  • Location:Canada

Posted 27 July 2016 - 04:50 PM

Yeah, congrats!  Big milestone.



#19 leokosta

leokosta
  • Members
  • 10 posts

Posted 27 July 2016 - 05:04 PM

Update 2: OK, I'v looked into the tp2 file and it turns out the file EET checks for in the BG:EE folder is not where it is supposed to be.

 

EET wants SoDAreas.bif to be in the /data/ folder but apparently modmerge puts the file into a folger called /sod-dlc/ instead. I'm not to sure what to do as /sod-dlc/ holds a number of duplicate files form /data/ so even if I moved/copied the file over into data the installation would probably still run into some issues.

 

Thats very concerning. I hope we can use EET on GOG version in the future.



#20 Ulb

Ulb
  • Members
  • 188 posts
  • Gender:Male

Posted 27 July 2016 - 05:31 PM

Update 3:

 

I managed to install EET (with warnings though).

 

So, hoping that EET would just follow the chitin.key and actually use the duplicate files from both folders, I went ahead and just copied the /sod-dlc/ files over into /data/ (not including the duplicate files of course) and tried to install it.

 

In hindsight it was stupid of me to actually copy the files over instead of editing the file check in the tp2 file since now I can't be too sure if it actually worked. There are only like 4 or 5 duplicated files and since the majority of the sod stuff was in the data folder as well it might mean very little that the SoD campaign seems to run just fine. (Side note: I don't have any graphical issues in the SoD starting area and the fog displays just fine.)

 

Barring any new advice in this thread I'll go ahead and try to re-install EET tomorrow morning, this time just edition the tp2 file.

 

PS: The forum doesn't like .7z files and I'm tried so I'll upload the debug file tomorrow if it is of any help.


Edited by Ulb, 27 July 2016 - 05:31 PM.


#21 K4thos

K4thos
  • Modders
  • 1208 posts
  • Gender:Male

Posted 27 July 2016 - 05:45 PM

1. The GUI is a bit mixed up. It appears to use elements from SoD with the BG2 GUI:

Yeah, that dialogue boarder in BG2:EE GUI is a known issue. No idea what MOS, PVRZ, BAM file is that particular one.Maybe one of those weird box1-5.bam files that use PVRZ files differently or something weird like that. Forgot to mention it in release topic since I prefer SoD GUI (you can install it via setup-EET_end) which doesn't have this problem.
 

2. There is a graphics bug in the opening map of SoD:

 

Are you sure that you didn't remove fpYUV.GLSL file from your override? That's the file responsible for this effect. Please compare content of this file with the one in EET/base/glsl/ directory.
 

 I was asking if it didn't work

 

 not yet
 

EET wants SoDAreas.bif to be in the /data/ folder but apparently modmerge puts the file into a folger called /sod-dlc/ instead. I'm not to sure what to do as /sod-dlc/ holds a number of duplicate files form /data/ so even if I moved/copied the file over into data the installation would probably still run into some issues.

 

RC2 with support for GOG and Steam versions will be released tomorrow (going sleep now) I expected that modmerge extracts files to override rather than unique directory. Thanks for report.

 

(Side note: I don't have any graphical issues in the SoD starting area and the fog displays just fine.)

The initial area fog works fine for me too. The problematic effect in my game is the one reported on redmine (apparently bug also happens on vanilla SoD although I don't have it there).


Edited by K4thos, 27 July 2016 - 06:27 PM.


#22 Mike1072

Mike1072
  • Gibberling Poobah
  • 2531 posts
  • Gender:Male
  • Location:Canada

Posted 27 July 2016 - 05:48 PM

PS: The forum doesn't like .7z files and I'm tried so I'll upload the debug file tomorrow if it is of any help.

 

I've added .7z to the list of allowable filetypes.



#23 smeagolheart

smeagolheart
  • Members
  • 95 posts
  • Gender:Male

Posted 27 July 2016 - 06:57 PM

I got an error at some point since my install is on my d: drive.

 

It wanted to do d:\documents\something I think looking for the saves in eet-end



#24 ALIENQuake

ALIENQuake
  • Modders
  • 629 posts
  • Gender:Male
  • Location:Poland

Posted 27 July 2016 - 10:23 PM

Congratulations on the first official release! Finally, modern IE Engine worlds can be united  :jump:  :worship:  



#25 Etamin

Etamin
  • Members
  • 51 posts
  • Gender:Male

Posted 27 July 2016 - 11:46 PM

I suggest creating topic at Beamdog forum.



#26 Ulb

Ulb
  • Members
  • 188 posts
  • Gender:Male

Posted 28 July 2016 - 01:59 AM

I just finished a small installation with SCS and some tweak mods using an edited tp2 file and everything seems to work fine so far. Will keep you updated.

 

@Mike Thanks, that will surely come in handy. :)

@Etamin I guess K4htos wants to wait for the actual release version before he makes a big announcement over there.



#27 argent77

argent77
  • Modders
  • 823 posts
  • Gender:Male

Posted 28 July 2016 - 02:10 AM

 

2. There is a graphics bug in the opening map of SoD:

Are you sure that you didn't remove fpYUV.GLSL file from your override? That's the file responsible for this effect. Please compare content of this file with the one in EET/base/glsl/ directory.

 

You're right. I forgot to disable my user override folder for that test. :p



#28 Etamin

Etamin
  • Members
  • 51 posts
  • Gender:Male

Posted 28 July 2016 - 03:23 AM

There's problem with polish instalation. After like 30 mins of working WeiDU shows error with coping EET/temp/BEREGOST.webm file and the again asks about installing core component. I reinstalled both SoD and BGII and this bug didn't disappear.

I attach debug file: http://speedy.sh/p2Yy2/SETUP-EET.DEBUG


Edited by Etamin, 28 July 2016 - 04:30 AM.


#29 K4thos

K4thos
  • Modders
  • 1208 posts
  • Gender:Male

Posted 28 July 2016 - 05:26 AM

There's problem with polish instalation. After like 30 mins of working WeiDU shows error with coping EET/temp/BEREGOST.webm file and the again asks about installing core component. I reinstalled both SoD and BGII and this bug didn't disappear.

thanks for report, found the problem. It will be fixed later today with RC2 release. Although the log shows that the installer was trying to install EET using en_US TLK files. BG2:EE doesn't support Polish language officially yet, but installer checks TLK files presence anyway. Did you have dialog.tlk file in lang/pl_PL/ directory when you started the installation? (It's distributed on Beamdog forums). Btw. later today I will also update this mod to properly show Polish language from the options screen (patch 2.x force us to also patch BG:EE LUA to add new language and the mod was released for patch 1.3). Unfortunately viader is missing in action, so the mirror linked in this topic won't be updated for some time.

 

edit

I got an error at some point since my install is on my d: drive.

 

It wanted to do d:\documents\something I think looking for the saves in eet-end

this is not really an error. Just a workaround until this feature is implemented in weidu. In future this code will be used:

REQUIRE_PREDICATE FILE_EXISTS ~%USER_DIRECTORY%/save/saves.tra~ @910005 //%USER_DIRECTORY%/save/saves.tra doesn't exist
REQUIRE_PREDICATE FILE_EXISTS ~%USER_DIRECTORY%/save/saves.txt~ @910006 //%USER_DIRECTORY%/save/saves.txt doesn't exist

but since it can't be implemented yet the check that skips component installation is done directly in code

OUTER_PATCH_SAVE USER_DIRECTORY ~%USER_DIRECTORY%~ BEGIN
    REPLACE_TEXTUALLY ~Baldur's Gate II - Enhanced Edition~ ~Baldur's Gate - Enhanced Edition Trilogy~
END
ACTION_FOR_EACH ext IN tra txt BEGIN
    ACTION_IF NOT FILE_EXISTS ~%USER_DIRECTORY%/save/saves.%ext%~ BEGIN
        FAIL @910005 //%USER_DIRECTORY%/save/saves.%ext% doesn't exist. Skipping installation. Saves won't be updated.
    END
EN

Edited by K4thos, 28 July 2016 - 05:38 AM.


#30 Etamin

Etamin
  • Members
  • 51 posts
  • Gender:Male

Posted 28 July 2016 - 06:49 AM



 

There's problem with polish instalation. After like 30 mins of working WeiDU shows error with coping EET/temp/BEREGOST.webm file and the again asks about installing core component. I reinstalled both SoD and BGII and this bug didn't disappear.

thanks for report, found the problem. It will be fixed later today with RC2 release. Although the log shows that the installer was trying to install EET using en_US TLK files. BG2:EE doesn't support Polish language officially yet, but installer checks TLK files presence anyway. Did you have dialog.tlk file in lang/pl_PL/ directory when you started the installation? (It's distributed on Beamdog forums). Btw. later today I will also update this mod to properly show Polish language from the options screen (patch 2.x force us to also patch BG:EE LUA to add new language and the mod was released for patch 1.3). Unfortunately viader is missing in action, so the mirror linked in this topic won't be updated for some time.

 

 

The only way to install polish text and dubbing in BG2:EE is described by TartamPuan in this topic: https://forums.beamd...-instalacja/p21

 

I wanted to do it later, since i didn't know this won't prevent EET installation. Now i first installed translation by this method and then started EET installation, which this time finished ("due to errors").

 

EDIT: Just launched the game and translation is completly broken. UI is in english, first movie (Zbudowana na szczycie skał....) has no sound, NPCs have randomly no voices, english voices or polish voices and most entries and dialogues has "Invalid value":

 

Baldr000.jpg

 

Baldr001.jpg


Edited by Etamin, 28 July 2016 - 08:02 AM.




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users