Jump to content

Photo

Trouble getting fonts working on Linux


1 reply to this topic

#1 MG913

MG913
  • Members
  • 1 posts

Posted 25 January 2018 - 01:12 PM

Hi, I have been trying to get Icewind Dale 2 working on Ubuntu 16.04. I started with the build on the repo, it works with the base font but character dialogue isn't rendering correctly. I tried to replace it with another font but then I get a segmentation fault.

 

Spoiler

 

After that I tried that latest dev build off the website. It works fine and doesn't have the issue with the text, but its still small and I would like to change it. Trying to change the font makes it crash after the intro videos. I couldn't find the plugins with this build, I didn't know if they weren't included or if you had just changed the way you handled them, but that might be the cause of the crash.

 

Spoiler

 



#2 lynx

lynx
  • Modders
  • 3119 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 27 January 2018 - 02:35 PM

The dev build is static, that's why there's no plugin loading output. However custom fonts worked for me pretty recently, so I don't have much to go on. Do you get the crash with something other than freesans too? What did you change in fonts.2da?

 

btw, that ubuntu package is two versions behind. Bionic currently has the latest.


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Play android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users