Jump to content


Photo

[Testers Wanted] Tweaks is dead. Long live Tweaks!


155 replies to this topic

#151 Roxanne

Roxanne
  • Modders
  • 1369 posts
  • Gender:Not Telling

Posted 04 July 2017 - 12:03 PM

Component 3183 // Romance Cheats

can create bugs (endless loops + stuttering) in relation to mod added romances,

 

The no_kill additions to the vanilla NPC's override scripts reset romance status to 1 whenever it is !1 and respective LoveTalk is below the value for romance=2,

If a mod NPC romance reaches status 2, it may set other romances to 3 (as it is not captured by tweaks) - example Isra mod - however the tweaks code sets it back to 1 and so on and so on.

 

See this example http://www.shsforums...ce/#entry595643


The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#152 CamDawg

CamDawg

    Seven billion ton robot monster

  • Gibberling Poobah
  • 9129 posts
  • Gender:Not Telling

Posted 04 July 2017 - 03:51 PM

Yes, this is explicitly warned about in the readme. Twice.


I came here with a simple dream: a dream of killing all humans. And this is how it must end? Who's the real seven billion ton robot monster here? Not I. Not... I.


#153 Mirrorman95

Mirrorman95
  • Members
  • 17 posts
  • Gender:Male

Posted 04 July 2017 - 08:42 PM

I posted this on the Tweaks Anthology Beamdog topic a few days ago, but I've since had no reply, so I'm posting it here in the hopes I'll receive a response.

 

I recently tried to install Tweaks Anthology v1 to my copy of PsT:EE, but I had to stop, because I kept getting asked if I wanted to install mods that the current readme says are incompatible with Planescape. To be fair, the installer did identify some of the incompatible mods and skipped them as it should. But when it kept asking me if I wanted to install incompatible mods it should have skipped, like Remove Helmet Animations, Avatar Morphing, BG Casting Graphics, and IwD Casting Graphics, I quit the installer and re-ran it just long enough to uninstall the few mods I had installed with it. I figured if the installer was behaving this way, it might not be fully compatible with Planescape Enhanced yet.
Can someone fix the Tweaks Anthology to correctly skip all the mods PsT:EE isn't compatible with? If that isn't possible at this time, could someone at least assure me of whether or not the installer is in fact working properly, so I can at least still install the Anthology by skipping all the incompatible mods manually during installation?



#154 Roxanne

Roxanne
  • Modders
  • 1369 posts
  • Gender:Not Telling

Posted 04 July 2017 - 11:50 PM

Yes, this is explicitly warned about in the readme. Twice.

Yes it is. Twice.

So unless somebody can identify the mods that can conflict with this component (the warning is just a general disclaimer), it may be best to remove this from BWS installs?


Edited by Roxanne, 04 July 2017 - 11:51 PM.

The Sandrah Saga

another piece of *buggy, cheesy, unbalanced junk*


#155 CamDawg

CamDawg

    Seven billion ton robot monster

  • Gibberling Poobah
  • 9129 posts
  • Gender:Not Telling

Posted 08 July 2017 - 04:56 PM

I posted this on the Tweaks Anthology Beamdog topic a few days ago, but I've since had no reply, so I'm posting it here in the hopes I'll receive a response.
 
I recently tried to install Tweaks Anthology v1 to my copy of PsT:EE, but I had to stop, because I kept getting asked if I wanted to install mods that the current readme says are incompatible with Planescape. To be fair, the installer did identify some of the incompatible mods and skipped them as it should. But when it kept asking me if I wanted to install incompatible mods it should have skipped, like Remove Helmet Animations, Avatar Morphing, BG Casting Graphics, and IwD Casting Graphics, I quit the installer and re-ran it just long enough to uninstall the few mods I had installed with it. I figured if the installer was behaving this way, it might not be fully compatible with Planescape Enhanced yet.
Can someone fix the Tweaks Anthology to correctly skip all the mods PsT:EE isn't compatible with? If that isn't possible at this time, could someone at least assure me of whether or not the installer is in fact working properly, so I can at least still install the Anthology by skipping all the incompatible mods manually during installation?

I saw the post, and I am looking into it. IIRC, the GAME_IS wasn't detecting PSTEE very well on the WeiDU version that v1 shipped with so I went with a combo of PsT + some file checks. It's probably detecting correctly now, which means those checks now work correctly and my workaround fails.  
 

 

Yes, this is explicitly warned about in the readme. Twice.

Yes it is. Twice.
So unless somebody can identify the mods that can conflict with this component (the warning is just a general disclaimer), it may be best to remove this from BWS installs?

 

It will conflict with pretty much any NPC mod with a romance, if the player pursues a romance with the mod NPC and any of the Bioware/Beamdog romances.

Even absent the conflicts, it never should have been recommended.


I came here with a simple dream: a dream of killing all humans. And this is how it must end? Who's the real seven billion ton robot monster here? Not I. Not... I.


#156 Opipo

Opipo
  • Members
  • 5 posts

Posted 11 July 2017 - 02:50 AM

Hi so this is the successor to the BG-Tweak pack?, because i installed it (bg tweak pack on bg2ee and it broke the shaman, the bg tweak pack did, not this mod, which i have not yet installed)





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users