Jump to content

Photo

EET Failure on 2.5 beta


23 replies to this topic

#1 enderandrew

enderandrew
  • Members
  • 30 posts

Posted 26 April 2018 - 11:36 AM

I had been testing EET (with BWS) on the 2.5 betas successfully previously, but now it fails to install on 2.5 beta.


ERROR: Failure("EET/TEMP/PATCH/ARE/BG2200.ARE: read out of bounds")
PLEASE email the file SETUP-EET.DEBUG to K4thos (swit)
Automatically Skipping [EET core - resource importation] because of error.
Using Language [English]
[.\lang\en_us\dialog.tlk] created, 320392 string entries


NOT INSTALLED DUE TO ERRORS EET core - resource importation


D:\BWS\Baldur's Gate II Enhanced Edition>


ERROR: illegal 2-byte read from offset 13116190 of 13768-byte file EET/TEMP/PATCH/ARE/BG2200.ARE
ERROR: [EET/TEMP/PATCH/ARE/BG2200.ARE] -> [EET/TEMP/PATCH/ARE] Patching Failed (COPY) (Failure("EET/TEMP/PATCH/ARE/BG2200.ARE: read out of bounds"))
ERROR: Failure("EET/TEMP/PATCH/ARE/BG2200.ARE: read out of bounds")
Enhanced Edition Trilogy (Enhanced Edition Trilogy) was not installed due to errors.


Without this component the installation cannot be continued.

#2 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 11:44 AM

I had been testing EET (with BWS) on the 2.5 betas successfully previously, but now it fails to install on 2.5 beta.


ERROR: Failure("EET/TEMP/PATCH/ARE/BG2200.ARE: read out of bounds")
PLEASE email the file SETUP-EET.DEBUG to K4thos (swit)
Automatically Skipping [EET core - resource importation] because of error.
Using Language [English]
[.\lang\en_us\dialog.tlk] created, 320392 string entries


NOT INSTALLED DUE TO ERRORS EET core - resource importation


D:\BWS\Baldur's Gate II Enhanced Edition>


ERROR: illegal 2-byte read from offset 13116190 of 13768-byte file EET/TEMP/PATCH/ARE/BG2200.ARE
ERROR: [EET/TEMP/PATCH/ARE/BG2200.ARE] -> [EET/TEMP/PATCH/ARE] Patching Failed (COPY) (Failure("EET/TEMP/PATCH/ARE/BG2200.ARE: read out of bounds"))
ERROR: Failure("EET/TEMP/PATCH/ARE/BG2200.ARE: read out of bounds")
Enhanced Edition Trilogy (Enhanced Edition Trilogy) was not installed due to errors.


Without this component the installation cannot be continued.

You can try to verify with change-log on ar2200.are in BGEE (Cloackwood First area I think) if there is any mod that changes the file. I know of no EET-compatible mod that touches this are-file prior to EET, but then I do not know everything.

 

If that leads to no result, the only remaining source for this error that never was reported until the last 2.5beta came out would in deed be that new build. Whatever bean dogs do in the wood....?


The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 


#3 enderandrew

enderandrew
  • Members
  • 30 posts

Posted 26 April 2018 - 12:11 PM

I think BeamDog must have changed the file, because someone else who was getting the same error as me then reverted back to the non-beta version of BGEE/BG2EE and EET installed just fine.

So EET may have to do a version check and handle that different if you have 2.5 or don't.

#4 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 12:17 PM

I think BeamDog must have changed the file, because someone else who was getting the same error as me then reverted back to the non-beta version of BGEE/BG2EE and EET installed just fine.

So EET may have to do a version check and handle that different if you have 2.5 or don't.

This implies that whatever they did to the are was a valid change and not a mistake.

read out of bounds

 

this is not something that just appears if you tweak some existing are-file unless you screw something up.

 

Before everyone panics and hastily tries to implement solutions on their end, why not wait until the source may be fixed. We are talking about some beta version out for testing vs a community using their stuff that works.


The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 


#5 enderandrew

enderandrew
  • Members
  • 30 posts

Posted 26 April 2018 - 12:39 PM

I agree that Beamdog likely changed the file intentionally and it was not a mistake.

I'm just giving you guys a heads up that EET will likely have to be updated when 2.5 final comes out, where as previously it looked like all the mods were installing the same on the 2.5 beta with no problems.

I can upload a version of BG2200.ARE from the 2.5 beta if you want to compare differences.

#6 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 12:47 PM

I can upload a version of BG2200.ARE from the 2.5 beta if you want to compare differences.

 

Good idea!


The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 


#7 argent77

argent77
  • Modders
  • 823 posts
  • Gender:Male

Posted 26 April 2018 - 01:25 PM

I was curious myself and installed EET on the latest 2.5 patches. My installation failed on this particular ARE file as well. I was able to track the issue to several invalid or conflicting actor definitions within the ARE file that EET seems to choke on.

I have created a small mod that fixes these inconsistencies: EET-ARE_fix-v2.zip

Run this mod on BG1EE before starting the EET installation.

EET will still finish with a couple of warnings, which may or may not affect gameplay in some way.

Edit: Uploaded a fixed version that doesn't produce log entries.

Edited by argent77, 26 April 2018 - 01:43 PM.


#8 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 01:30 PM

I was curious myself and installed EET on the latest 2.5 patches. My installation failed on this particular ARE file as well. I was able to track the issue to several invalid or conflicting actor definitions within the ARE file that EET seems to choke on.

I have created a small mod that fixes these inconsistencies: EET-ARE_fix-v1.zip

Run this mod on BG1EE before starting the EET installation.

EET will still finish with a couple of warnings, which may or may not affect gameplay in some way.

Genius.

 

Do you have by any chance those warnings logged?


The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 


#9 argent77

argent77
  • Modders
  • 823 posts
  • Gender:Male

Posted 26 April 2018 - 01:36 PM

Sure, here it is: SETUP-EET.zip



#10 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 01:37 PM

 

I was curious myself and installed EET on the latest 2.5 patches. My installation failed on this particular ARE file as well. I was able to track the issue to several invalid or conflicting actor definitions within the ARE file that EET seems to choke on.

I have created a small mod that fixes these inconsistencies: EET-ARE_fix-v1.zip

Run this mod on BG1EE before starting the EET installation.

EET will still finish with a couple of warnings, which may or may not affect gameplay in some way.

Genius.

 

Do you have by any chance those warnings logged?

 

Another question

Would not EET fail with the message that the "EET preparation: Fix ARE actor offsets" mode is unknown when it checks the list of mods to be imported from BGEE? Unless you delete this entry from Weidu.log.


The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 


#11 argent77

argent77
  • Modders
  • 823 posts
  • Gender:Male

Posted 26 April 2018 - 01:39 PM

Good question. I've installed EET after fixing the ARE file manually. The mod has been created afterwards. I'll do another installation with the mod installed and see what'll happen.



#12 ALIENQuake

ALIENQuake
  • Modders
  • 609 posts
  • Gender:Male
  • Location:Poland

Posted 26 April 2018 - 01:41 PM

Another question

 

 

Would not EET fail with the message that the "EET preparation: Fix ARE actor offsets" mode is unknown when it checks the list of mods to be imported from BGEE? Unless you delete this entry from Weidu.log.

 

It will cause EET to fail. The "EET preparation: Fix ARE actor offsets" must not add weidu.log entry. Direct patching EET is to much work.


Edited by ALIENQuake, 26 April 2018 - 01:42 PM.


#13 argent77

argent77
  • Modders
  • 823 posts
  • Gender:Male

Posted 26 April 2018 - 01:43 PM

I have already uploaded an updated version. See original post above.



#14 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 01:50 PM

I have looked at those warnings meanwhile. It appears to me that they are harmless - just probably irritating to the user,

They appear for patches inside of EET that can no longer be applied, my assumption is that the issues that EET tries to patch are already corrected in the new BGEE version.

However, this needs to be confirmed by someone who can look at the respective new files from 2,5.

 

It should not impact gameplay, but all EET users getting an *Installed with warning* is not a solution for long.


Edited by Roxanne, 26 April 2018 - 01:51 PM.

The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 


#15 Roxanne

Roxanne

    Modder

  • Modders
  • 2041 posts
  • Gender:Female
  • Location:Auckland, NZ

Posted 26 April 2018 - 10:39 PM

@argent77

Still one more question. Would applying your patch on a pre-2.5beta version of the area file have any effect or would it just do nothing?


The Sandrah Saga!

another piece of *buggy, cheesy, unbalanced junk*

 

 

 




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users