Jump to content


Photo

Version 7 dev release


  • This topic is locked This topic is locked
13 replies to this topic

#1 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 13 July 2013 - 03:27 PM

This is a proto version of Item Randomiser v7. It is not feature complete but rather than sitting on the changes until I have time to finish v7, I will release one or more development versions. This version is dated 170205.

Install:
Place the extracted files in your game directory.
Windows: follow the regular installation instructions
OS X: make the command file executable and run it, I guess
GNU/Linux: follow the regular installation instructions
 
Download.

Edited by Wisp, 01 May 2017 - 04:16 AM.


#2 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 24 July 2013 - 08:41 AM

Updated. New dev version is dated 130724 and actually installs. Can you ask for more?

#3 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 26 August 2013 - 10:02 AM

Update. New dev version is dated 130726 and does not do incomplete Mode 1 installs on BGEE (i.e., it won't crash your game). There's also a small correction for BGEE to the alterations to Unshey's quest (probably not worth upgrading over).

To upgrade, simply extract this version of the mod on top of your existing version and reinstall the main component. Choose to preserve saved-game compatibility if you have a game in progress. You don't need to upgrade if you use Mode 2.

#4 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 06 October 2013 - 10:19 PM

Update. The version dated 131007 fixes a small compatibility issue with SCS. It is safe to upgrade, but the fix will not affect creatures you have already encountered. Personally, I wouldn't upgrade over this. It is also packaged with WeiDU 232, so installation on BGEE is now done in the same way as on any other game.

Edited by Wisp, 06 October 2013 - 10:20 PM.


#5 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 18 November 2013 - 02:33 PM

The version dated 131118 features compatibility with BGII: EE, as well as improved compatibility with BG: EE.

#6 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 01 January 2014 - 09:28 AM

The version dated 140101 fixes a rare bug that could result in unobtainable items.

It is safe to upgrade from earlier versions but bugs you have already encountered will not be retroactively fixed.

Edit: the archive has been updated to include WeiDU. The OS X version is 64-bit, built on OS X Mavericks. Other OS X builds of WeiDU are available at weidu.org.

Edited by Wisp, 01 January 2014 - 11:54 AM.


#7 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 01 May 2014 - 08:19 AM

The version dated 140501 fixes the large number of wands and scrolls ond BG: EE.

Upgrading from earlier versions requires you to start a new game.

#8 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 20 July 2014 - 02:52 AM

The version dated 140720 disables the Polish translation, which was non-functional anyway. I'm disabling it rather than making it functional, because over the years the coverage of the translation has decreased and were I to install a Polish translation I would not expect 9 out of 10 new or altered strings to be in English. The translation will be re-enabled as soon as it is updated.



#9 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 30 August 2014 - 03:49 PM

The version dated 140831 re-enables the Polish translation. Many thanks to Cahir for the update! There are also some other minor fixes to some of the text.

#10 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 17 October 2015 - 05:28 AM

The version dated 151017 fixes an issue involving the BG1 engine. Randomised scrolls could be bought for cheap. This issue did not affect Tutu, BGT and other flavours of the BG2 engine. Re-installing with 151017 will not break saved games but will not fix scroll costs in stores you've already been to.

#11 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 10 January 2016 - 01:10 PM

The version dated 160110 introduces the following changes:

 

  • Randomised potions are not assigned a lore value.
  • Internal changes for fewer bugs.
  • Mode 1 installs on modern Perl environments (only relevant for OS X and GNU/Linux).
  • Add a new framework for allowing specific items and locations to have a unique chance of being included in the randomisation process. The feature is not yet in use.
  • Layene gets a replacement weapon.
  • Reorganise list files into a better-structured system.
  • The Manual of Bodily Health is not randomised on the BG1 engine, due to technical limitations.



#12 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 28 February 2016 - 02:16 AM

The version dated 160228 fixes a few compatibility issues.



#13 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 05 February 2017 - 12:04 PM

The version dated 170205 includes experimental support for EET. It's experimental in the sense I think it should perhaps work, but don't have SoD and can't test it. If someone who has EET could give it a try and report back, that would be super.



#14 Wisp

Wisp
  • Modders
  • 1087 posts
  • Gender:Male

Posted 06 February 2017 - 01:02 PM

The version dated 170206 includes less experimental support for EET.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users