Jump to content


Photo

I need some help to create new items


12 replies to this topic

#1 INeedSomeHelp

INeedSomeHelp
  • Members
  • 6 posts

Posted 25 July 2015 - 11:51 PM

Hi everybody,

 

I am trying to create some new items with DLTCEP, but I have some issues and there are some things that I do not understand.

 

First, when I run the setup, I get this message: There was an error while processing the effect description Errorcode:1. I get this message also when I launch the program.

Secondly, when I try to save an item, I get this message: You opened it read only!

 

Other questions:

 

If I want to create a harp, what kind of "Item Type" should I select?

If I want to create a shiny armor like the one you find in BG2, what effect should I select?

If I want an armor that does not disable spellcasting, what effect should I select?

How can I use new BAMs?

 

I tried to find a tutorial, but with no success.

 

Thanks in advance for your help.


Edited by INeedSomeHelp, 25 July 2015 - 11:52 PM.


#2 Fiann of the Silver Hand

Fiann of the Silver Hand
  • Modders
  • 387 posts
  • Gender:Male
  • Location:MURICA

Posted 26 July 2015 - 12:19 AM

The best thing is to copy and rename an item that exists already with a (the) characteristic(s) you want.


Edited by Fiann of the Silver Hand, 26 July 2015 - 12:19 AM.


#3 Avenger

Avenger
  • Modders
  • 3731 posts
  • Gender:Male
  • Location:Hungary

Posted 26 July 2015 - 12:27 AM

To make DLTCEP able to write files, you have to go to the setup and turn "read only" off. Also, make sure you set the editor up for the game type you use. Once you turn read-only off, it is your responsibility to not break your game.

 

1. If you want the harp to be equipped (held by hand), then use a shield. If it is enough to be in a quick slot, use wand, or something like that.

2. "Shiny" i don't know what you mean by this, but you say there is already one in BG2, so... check the effects of that item.

3. Same as point 2, check the effects on an existing item, most armor contain an equipping effect that disables casting. Delete that effect.

 

Note: since you most likely never went through the setup phase correctly, you likely don't see the effect descriptions. So, first of all, set the effect descriptions. 

This is the "location of IEEP effect descriptions (.dat file) part of the setup. Click on the folder icon, and browse for BG2Effects.dat 

 

Most of the setup is kinda automatic, if you select the game type, though.

Later, you might want to edit scripts, so you might want to integrate WEIDU (a script compiler).


Edited by Avenger, 26 July 2015 - 12:31 AM.


#4 INeedSomeHelp

INeedSomeHelp
  • Members
  • 6 posts

Posted 26 July 2015 - 01:03 PM

@Avenger

Thank you very much for your kind and helpful reply. I am not very good with this stuff, but I try to do my best.

I want to create some items for my boyfriend as a gift for his birthday since he likes so much BG and I want to use new icons - he dislikes recycling :)

Can I use new icons?

I ran again the setup fixing the effect description and I do not get again the error message.

Thank you!

 

PS: For "Shiny armor", I meant the armor you can find at Spellhold that glows... This one:

 

i1032486_Cattura.JPG

 

I tried to load this item, but I could not find it.


Edited by INeedSomeHelp, 26 July 2015 - 01:05 PM.


#5 lynx

lynx
  • Modders
  • 3031 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 26 July 2015 - 01:41 PM

It's called Jester's Chain. You can use the search when loading an item to find its resref. Then you'll also be able to see which files it uses for graphics ...


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#6 Avenger

Avenger
  • Modders
  • 3731 posts
  • Gender:Male
  • Location:Hungary

Posted 27 July 2015 - 07:08 AM

You can use new icons, but, creating the icons requires a combination of skills:

1. artistic ability to create the icons - it is basically 256 colors ~64x64 pixel, but it may slightly differ.

2. once you have a bmp if this type, you can convert it to the game's format by DLTCEP or BAMWorkShop 

 

When using original BG, create a 32x32 version of the image too, when using EE you need only one icon.

In dltcep: edit animation (bam) / file / load external bmp / select small icon bmp / frame / import frame / select large icon bmp / save as bam 

 

In the cycles section, if you have vanilla BG: frame 0 goes to cycle 1, and frame 1 goes to cycle 0 (really odd but this is how vanilla bams work).

You also need to apply 'center' on the large frame, enable RLE  for both frames and set externally compressed.

 

...

Ok, maybe this is tremendous manual work, especially for the first time. I believe BAMWorkshop has most of this automated (but old versions tend to screw the colors up).



#7 INeedSomeHelp

INeedSomeHelp
  • Members
  • 6 posts

Posted 27 July 2015 - 08:26 AM

OKAY! I can do this!

Your explanation is very good - thanks a lot!

I will let you know if everything works fine :)



#8 Fiann of the Silver Hand

Fiann of the Silver Hand
  • Modders
  • 387 posts
  • Gender:Male
  • Location:MURICA

Posted 27 July 2015 - 01:00 PM

NI has a bam converter, too.



#9 INeedSomeHelp

INeedSomeHelp
  • Members
  • 6 posts

Posted 29 July 2015 - 09:34 PM

I may be blind, but I really cannot find the Jester's Chain when I try to load an existing item.

I can find its BAM (ICHAN10), but not the item itself.



#10 lynx

lynx
  • Modders
  • 3031 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 29 July 2015 - 11:30 PM

it's CHAN10 :)


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#11 INeedSomeHelp

INeedSomeHelp
  • Members
  • 6 posts

Posted 30 July 2015 - 10:16 AM

See attachment.

I do not know why, but it is not in my "Load Item" list.

 

Attached Thumbnails

  • 1.JPG


#12 lynx

lynx
  • Modders
  • 3031 posts
  • Gender:Male
  • Location:Ljubljana, Slovenija

Posted 30 July 2015 - 11:47 AM

Are you sure this isn't bg1 you're looking at?


GemRB - IE anywhere.
Mages needed! Looking for Planescape: Torment testers
Market android version IS NOT SUPPORTED ANYMORE: reported bugs will be ignored! Still looking for builders ...

#13 INeedSomeHelp

INeedSomeHelp
  • Members
  • 6 posts

Posted 30 July 2015 - 12:15 PM

Doh!

You are right - now I see why I could not find the item.

Thanks!





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users